3

I installed Windows 10 and Ubuntu in dual boot. Every time I enter Windows 10, the next time I boot Ubuntu, my headphone jack does not respond, that is, the sound only plays through the speaker. At this point, the configuration is displayed, showing that there is only one sound card, and I actually have two.

This problem appears on Ubuntu 18.04 LTS and on 18.10. To get my headphones working after booting Windows and then Ubuntu, I have to turn off the computer and then turn on it. I can't bear it any more. I think this may be caused by Windows 10 somehow removing the Ubuntu driver.

How can I fix this problem?

3
1
+50

This is not a solution, but a workaround.

If you are still facing this problem, then when on Linux, open pavucontrol

pavucontrol

And then go to "Output Devices" tab, in the Built-In Audio Analog Stereo change port to "Headphones (Unplugged)"

If you do not have pavucontrol installed, install it by:

sudo apt install pavucontrol

A solution might be: In your kernel boot options, add acpi_osi=Linux

5
  • It worked when changed in pavucontrol to headphones(unplugged). Thanks a lot because I almost gave up on the ubuntu because of that.
    – Konrad
    Aug 1 '19 at 14:17
  • What if the 'headphones' option is not showing?
    – Konrad
    Aug 2 '19 at 11:11
  • Then go into Configuration (in pavucontrol) and in the Built-in-Audio (not HDMI), choose the profile Analog Stereo Duplex.
    – Domo N Car
    Aug 3 '19 at 10:28
  • Still It's not present.
    – Konrad
    Aug 5 '19 at 7:06
  • @KonradSitarz You then have a different problem than this one. Create a new question, and give information about lspci -vv and lsmod. Also look at superuser.com/questions/1312970/… , it looks like the problem you are facing.
    – Domo N Car
    Aug 5 '19 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.