1

Kernel: 4.15.0-43-generic x86_64 bits: 64
Desktop: KDE Plasma 5.12.7
Distro: Ubuntu 18.04.1 LTS

New user to Xubuntu since a couple of hours on an E580 ThinkPad.

Mobo: LENOVO model: 20KSCTO1WW v: SDK0J40709
UEFI: LENOVO v: R0PET47W (1.24 ) date: 08/29/2018
CPU: Quad core Intel Core i7-8550U (-MT-MCP-)

When pressing the Volume mute button the LED indicator light does not turn on.

Running alsamixer does not show me a mute LED mode with all devices tried.
amixer scontrols returns this.

Simple mixer control 'Master',0    
Simple mixer control 'PCM',0    
Simple mixer control 'Mic Boost',0    
Simple mixer control 'IEC958',0    
Simple mixer control 'IEC958',1    
Simple mixer control 'IEC958',2    
Simple mixer control 'IEC958',3    
Simple mixer control 'IEC958',4    
Simple mixer control 'Beep',0    
Simple mixer control 'Capture',0    
Simple mixer control 'Internal Mic Boost',0    

Checking this info https://www.thinkwiki.org/wiki/Mute_button.
My GRUB config from /etc/default/grub is as this.

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux"
GRUB_CMDLINE_LINUX="quiet splash acpi_osi=linux"

Running sudo update-grub and rebooting does not make the LED turn on when pressing the mute Volume button.

acpi_listen and pressing Fn + mute Volume button returns this.

button/mute MUTE 00000080 00000000 K

Checking this https://www.thinkwiki.org/wiki/Microphone_Mute_Button.
Thinking perhaps I can apply the same technique to the Volume mute button I checked these two locations and have this.

enter image description here

Is there anything I can do here in these folders?

Using the Kubuntu live USB key, the Volume mute button LED also does not work.

What can I do to get the Volume mute button LED working?

0

This works, with and without headphones, Volume mute button LED turns on and off.

alsactl restore

Then reboot, full shutdown.

  1. Start alsamixer in the terminal.

  2. Make sure you've selected the internal sound card (not the HDMI or external ones) by pressing F6.

  3. Try to locate a setting for LEDs, presented between the sliders, something like Mute-LED Mode. Use the to move to the right in case you have more sliders than fit on the screen.

  4. Move to the "slider" and adjust it using the and keys in order to find a Follow Master option (or alike). Also try to toggle the LED state manually by flipping the setting On/Off.

  5. Now move to the Master slider and press M to mute/unmute. The LED should toggle with it.

  6. Try to use the hotkeys to mute/unmute. The LED should toggle with it again.

enter image description here

Reference

Apart from this all the hardware was recognised during install and the system runs stable, all hotkeys work as expected, super happy with the E580 running Kubuntu.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.