1

I have a home NAS accessed via smb share.

I used ubuntu 16.04 before and everythings fine. After I changed to 18.04, (not upgrading but erase-and-installing a new system, with the /home mounted at a different drive so not changed), It seems fine until I found all the folders in the NAS can only be read, any write operation will give an error.

I installed Xubuntu 18.04 first, when I tried to create a new folder in a NAS folder, the error message is :

Fail to create directory "New Folder". Function not implemented. Do you want to skip it?

I tried Ubuntu 18.04 and get the same. And if I re-install the system with 16.04, the problem is gone.

I searched internet but couldn't find the answer. I found 16.04 and 18.04 have different cifs module versions, 16.04's cifs.ko is V2.08, while in 18.04 it's V2.10, is this the cause ? how to fix it?

p.s.:

If I mount the NAS folder by command line using:

sudo mount.cifs -o user=username,pass=mypwd //192.168.1.254/Documents /mnt

it can mount correctly, buy when I try to create a new file or folder in /mnt , I got this error:

mn$ mkdir sjk
mkdir: cannot create directory ‘sjk’: Operation not supported

or

mnt>$ touch test
touch: cannot touch 'test': Operation not supported

Can anybody help with it?

  • 2
    Welcome to Ask Ubuntu. At Ubuntu 17.10 I found I needed to add a ,vers=1.0 to my cifs/samba parameters, so I'd try that. I primarily rely on NFS, using NFS devices only for backup so haven't paid much attention, but I have a number of parameters on mine you don't have "sec=ntlm,iocharset=utf8,vers=1.0,dir_mode=0777,file_mode=0777" but I'd suspect the version was what you are missing (version bump made to avert WannaCry on windows clients) – guiverc Jan 1 at 12:29
  • Thanks vuiverc, I've tried to use the vers=xxx methods but seems not helping. As it will be back to normal if downgraded to 16.04, I reckon it would be a bug in 18.04? – Jian Jiao Jan 2 at 3:53
  • I doubt a bug in 18.04, lots of people would have had it, and it would have been reported (bugs aren't bugs until they have been reported [& confirmed] on launchpad.net for Ubuntu, and I can't find any). Did you try the sec=ntlm too? I added the other lines in from my NAS lines so you could use them to try (as stated; I don't rely on samba but needed to add that on my mount some time back (I forget which Ubuntu version but it was long ago) for it to work for my devices. – guiverc Jan 2 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.