0

I'm unable to successful install Ubuntu 18.04.1 on my new desktop. I have Windows 10 Home installed and running smoothly, I successfully partitioned my HDD and SSD in halves so there is plenty of space to install Ubuntu, and the ISO I burned on my 8GB flashdrive works just fine when I boot my laptop from it.

When I try to boot my desktop from it, I get the normal grub menu, but when I select Install Ubuntu it doesn't work properly.

The first thing that happens is a bunch of lines on the screen saying "Completion-Wait loop timed out".

Then it flashes and I get a much longer string of messages, most of which is letters and numbers and symbols strung together.

At the end is says "end Kernel panic - not syncing: Fatal exception in interrupt"

Now, a few times when I've tried booting my desktop, it made it all the way to the Ubuntu loading screen. That quite got my hopes up, but it crashed and went to some similar black screen full of strange messages.

Secure boot is disabled in my BIOS. I tried editing the "Install Ubuntu" command in grub and adding "nomodeset" but that didn't work.

EDIT: I have successfully dual booted my system now and determined the source of my problem.

I'm running AMD Ryzen 3 2200g CPU and Gigabyte Radeon RX570 GPU, and they don't always play nice, I think due to the processor having integrated graphics. I removed my GPU and it booted from my ISO stick first try with no problems.

When I plug my GPU back in it won't boot up again though. I have installed the latest and greatest drivers from AMD for Ubuntu 18.04 but it still won't boot up in Ubuntu when I have my GPU connected.

  • What kind of computer is it? – Kristopher Ives Dec 31 '18 at 0:03
  • Have you checked the MD5SUM of the downloaded ISO? – C.S.Cameron Jan 7 '19 at 3:05
  • No but the ISO should be good, it installed like a champion on integrated graphics and worked just fine on my laptop as well – G Ghost Jan 8 '19 at 20:19
1

Some systems have strange support for UEFI modes which can be resolved by either updating the system firmware or worked around by either running with a special parameter or running in "legacy" mode to disabled UEFI features.

If you want to keep UEFI mode and try to boot Linux, add this to your boot options in GRUB like you tried with the nomodeset option:

amd_iommu=off

Instead if you want to avoid the whole UEFI problem simply enable "legacy" mode in in your BIOS options. Note that if you enable legacy mode you may have to create a different USB thumb drive when booting.

Source: https://bbs.archlinux.org/viewtopic.php?id=224265

|improve this answer|||||
  • If Widnows is UEFI on gpt drive, do not enable CSM/Legacy/BIOS boot mode. Windows & Ubuntu need to be in same boot mode either both UEFI or both BIOS. – oldfred Dec 31 '18 at 4:34
0

Same problem with Ryzen 5 2400g + RX570. Motherboard is Asus Prime A320M. Spent hours trying to get it working and finally I've managed to do so.

Here is the solution: In Bios NB settings primary card should be set to PCIE and integrated graphics should be ENABLED.

With this settings Ubuntu boots normaly on RX570, no glitches and full speed performance.

Once I disable integrated GPU all the problems are back: - not booting - booting without USB support - kernel panic - AMD-VI timeouts etc..

Drawback of this solution: Integrated GPU is using 1,2GB RAM so if you are on a 8GB, only 6,8 will be avaliable for software.

If anyone needs more info about this problem just ping me, I'm willing to help.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.