1

I was/am running Ubuntu 18.04 (upgraded from at least 2 previous LTS versions if it matters). Everything was working, including sound.

Just upgraded the motherboard to a B450 Tomahawk (Ryzen 5 2600x). Now sound doesn't work. I have speaker in the "line out" in back off the motherboard and headphones in front, there is no sound from either in tests. So I think this has to be a driver/module issue -- probably.

I tried killing pulseaudio and removing ~/.config/pulse/* and ~/.pulse* then rebooted ... still doesn't work.

lspci shows this for audio:

1c:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
1e:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

I think the 2nd is what I need. Looking at lsmod, I see:

snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek   106496  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  3
snd_hda_codec         126976  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              20480  1 snd_hda_codec
snd_pcm                98304  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  17 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
soundcore              16384  1 snd

So I think it should find the generic device first, which should cause it to use the realtek device. Doing "aplay -l" gives me:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So generic is an ALC892, which I can read that others have made work. Going into KDE's "System Settings" -> Mutlimedia -> AudioVolume -> Advanced, I've turned the GK107 HDMI off and I have "Family 17h HD Audio Controller" set to "Analog Stereo Output" (I've also tried "Analog Stereo Duplex"), but I still don't get sound -- tried with aplay and qmmp.

What else can I look for or do to solve this? Would it really require a fresh install to detect everything correctly?

Suggestions greatly appreciated. :)

(updated to show device selection) device selection

(update 2) Just found this in the output of "dmesg", so it looks like it's finding the ALC892 device.

[    5.029406] snd_hda_intel 0000:1c:00.1: Disabling MSI
[    5.029412] snd_hda_intel 0000:1c:00.1: Handle vga_switcheroo audio client
[    5.041312] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    5.041314] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.041315] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    5.041315] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    5.041316] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    5.041317] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[    5.041318] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    5.041319] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    5.055494] input: HD-Audio Generic Front Mic as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input5
[    5.055578] input: HD-Audio Generic Rear Mic as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input6
[    5.055654] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input7
[    5.055745] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input8
[    5.055849] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input9
[    5.055953] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input10
[    5.056054] input: HD-Audio Generic Line Out Side as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input11
[    5.056251] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:1e:00.3/sound/card1/input12
  • 1
    Can you change the default output device in your sound settings? – Kristopher Ives Dec 30 '18 at 22:33
  • This dialog: i.imgur.com/nLt563C.png – Kristopher Ives Dec 30 '18 at 22:38
  • You mean like this? (see update at end of post) – KBrannen Dec 31 '18 at 1:40
  • To follow up for anyone else searching for answer for this problem. I haven't been able to find a solution. Instead, I bought a SB Audigy FX PCIe card, installed it, turned off the onboard audio. Still didn't work, at least I couldn't find it in the audio devices. But I had the KUbuntu disk and tried a live image and it played sound just fine. :) So I installed KUbuntu to an extra partition so I could still get settings off the old root partition and all is good now. It really sucks I had to go buy an audio card when the MB has audio on it, but I like the MB otherwise, so this is what I have. – KBrannen Jan 15 at 3:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.