1

I have a gamepad Tronsmart Mars G02 which is connected to my laptop by USB transmitter.

Previously it worked without any problems on Ubuntu 16.04. But I replaced my HDD and installed Ubuntu 18.04 and now I cannot make gamepad working.

Here is a part of dmesg:

[ 2171.036631] usb 2-1.1: new full-speed USB device number 8 using ehci-pci
[ 2171.146376] usb 2-1.1: New USB device found, idVendor=2563, idProduct=0575
[ 2171.146380] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2171.146383] usb 2-1.1: Product: PS3/PC Gamepad
[ 2171.146386] usb 2-1.1: Manufacturer: SHANWAN
[ 2171.149335] input: SHANWAN PS3/PC Gamepad as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/0003:2563:0575.0004/input/input19
[ 2171.209186] hid-generic 0003:2563:0575.0004: input,hidraw2: USB HID v1.10 Gamepad [SHANWAN PS3/PC Gamepad] on usb-0000:00:1d.0-1.1/input0
[ 2182.292062] usb 2-1.1: USB disconnect, device number 8
[ 2182.568355] usb 2-1.1: new full-speed USB device number 9 using ehci-pci
[ 2182.679955] usb 2-1.1: New USB device found, idVendor=045e, idProduct=028e
[ 2182.679963] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2182.679968] usb 2-1.1: Product: Controller
[ 2182.679972] usb 2-1.1: Manufacturer: SHANWAN
[ 2182.681010] input: Microsoft X-Box 360 pad as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input20
[ 2184.362618] input: Microsoft X-Box 360 pad as /devices/virtual/input/input21

Here is a list of items from the evtest command:

sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:  Lid Switch
/dev/input/event1:  Power Button
/dev/input/event2:  Power Button
/dev/input/event3:  AT Translated Set 2 keyboard
/dev/input/event4:  Video Bus
/dev/input/event5:  Video Bus
/dev/input/event6:  Logitech USB Receiver
/dev/input/event7:  Logitech USB Receiver
/dev/input/event8:  ETPS/2 Elantech Touchpad
/dev/input/event9:  HDA Intel PCH Mic
/dev/input/event10: HDA Intel PCH Headphone
/dev/input/event11: HDA Intel PCH HDMI/DP,pcm=3
/dev/input/event12: Microsoft X-Box 360 pad
/dev/input/event13: WebCam SC-0311139N
/dev/input/event14: Microsoft X-Box 360 pad
Select the device event number [0-14]: 

I tried to choose 12 and 14 but didn't receive any reaction on gamepad buttons pressing.

So, it seems like ubuntu sees my gamepad but doesn't recognize any buttons click or stick moves.

Any ideas what to check or how to configure the gamepad?

0

Not that you should have to do this, but apparently this works for some people from Reddit:

sudo modprobe -r xpad
sudo modprobe xpad

This basically removes the xbox driver and adds it back.

  • I executed these commands and checked gamepad with evtest. This hasn't helped me :( Anyway, thanks. – Aleksandr Dec 30 '18 at 22:50
  • Not that it should make sense, but if you create a new user and login using that does the gamepad work? My thinking is maybe an old configuration file from before the change in how the driver worked might be messing with something? – Kristopher Ives Dec 30 '18 at 22:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.