3

---- I edited this question few times, because I am slowly figuring it out.----

Specs:

AMD FX 8320, Gigabyte GA-970A-UD3P, Radeon R9 390

Recent problem:

After succesfully installing amdgpu-pro (to do so, I need to add iommu=soft in grub AND use another graphic card or just use nomodeset) and rebooting, computer hangs at FSCK line: "/dev/sdb2: clean, / files, / blocks". Looks like system is corrupted and can not go further.

Main question:

What do I need to change? Some settings in BIOS, some line in grub (specific for my hardware) OR simply some hardware? Is the problem in graphic card or in motherboard, maybe cpu? Looks like graphic drivers bloke something.

Recent circumstances:

  • I added GRUB_CMDLINE_LINUX=»iommu=soft« in grub file with sudo nano /etc/default/grub
  • I installed Amdgpu-pro drivers (to do this, I had to temporarily change graphic card or use nomodeset)
  • I enabled IOMMU, Port 60/64 Emulator, XHCI Hand-off and EHCI Hand-off in BIOS
  • No additional drivers available in Software&Updates
  • After installing amdgpu-pro it looks like some things in system do not work (for instance I cannot open Settings - nothing happens)

How problems started:

I tried to switch to Linux from Windows 10. So I made new partition and tried to dual boot W10 and Ubuntu 18.04. But, mouse and keyboard did not work and I instantly got blackscreen with Ubuntu. After searching for solution I found »nomodeset« line. I added it to grub and I was succesfully able to try and to install ubuntu. But only with mouse and keyboard (and bootable usb stick) pluged in USB 3 ports. USB 2 ports were not working. I later managed to solve this USB problem by adding »iommu=soft« to grub and by enabling IOMMU, Port 60/64 Emulator, XHCI Hand-off and EHCI Hand-off in BIOS. Nice, so I could get in installed Ubuntu (with nomodeset –> low resolution) and all ports are working (network, Usb). Problem with USB 2 was known for Gigabyte GA-970A series of mobos, as people found out in other topics (iommu=soft and bios settings supposedly solved this for all users). So to start with, this type of mobo is problematic with linux. Is it responsible for my next problem?

So, now we come to the new big problem: I could not install graphic drivers. Software&Updates program found NO additional drivers and because of »nomodeset« I was unable to install downloaded Amdgpu-pro drivers, because I got message »WARNING: nomodeset detected in kernel parameters, amdgpu requires KMS«. Someone in this thread suggested to temporarily change graphic card (I did this with Nvidia 6600) in order to install drivers and then change it back to my Radeon R9 390. I did this. By changing card to Nvidia 6600 and with all settings above (iommu-soft and listed bios settings) I was able to install Amdgpu-pro drivers (Radeon™ Software for Linux® Driver for Ubuntu 18.04.2, Revision Number 19.10, Release Date 4/19/2019).

And with this succesfull install of Amdgpu-pro drivers we come to my recent problem: After succesfull install of Amdgpu-pro drivers, I restarted system. After selecting »Ubuntu« in Grub, I get empty purple screen for about 10 second and than blackscreen. Even if I try to boot with »nomodeset« in grub, I get the same blackscreen, but before that I get message in upper left corner:
/dev/sdb3: clean, 196026/1875968 files, 1728998/7492096 blocks.
I am running dual boot (W10 on one hard drive - works normally) and Ubuntu on another hard drive (sdb3 partition).

I have also tried instalation on clean disc (withouth dual boot), but the problem stays the same. I can install system using another graphic card (with iommu=soft in grub), then I can normally install amdgpu-pro for my R9 390, when I reboot after driver instalation is completed, computer hangs at "/dev/sdb2: clean, / files, / blocks". This looks like the sistem is corupted and it cannot go anywhere after FSCK check. If I try installation of Ubuntu directly with R9 390, I need to use "iommu=soft nomodeset" in grub. But still - after succesfully installing amdgpu-pro and rebooting, computer also hangs at "/dev/sdb2: clean, / files, / blocks". I have repeated instlation of Ubuntu and drivers few times and I always have the same problem.

Questions:

  1. Is the problem in motherboar or in graphic card?
  2. Is there any way to maybe set some parameters in grub (as I did with nomodeset) to select, which drivers must start? I am wondering if there is some clach of graphic drivers? Maybe kernel drivers and installed amdgpu-pro? What can I do in grub?
  3. Do I need to adjust BIOS settings somehow?

My BIOS settings: enter image description here enter image description here enter image description here

GRUB settings for "Ubuntu": enter image description here

Bottom line: At this point, I am totaly lost and I am starting to thing that this just wont work on my hardware. Would the change of hardware theoreticaly solve anything? I could buy another used 970 mobo... Maybe this? Thank you for all help and greetings!

  • KMS means Kernel Mode Set, which is being disabled when you add the nomodeset boot option. – Kristopher Ives Dec 31 '18 at 0:11
  • Have you tried using the built in Ubuntu Drivers manager instead of using the AMD download? It's often much better / easier to use the built in software from Ubuntu than to download proprietary third party stuff. – Kristopher Ives Dec 31 '18 at 0:14
1

I don't have an answer, but I'm experiencing exactly the same thing. amdgpu-pro-18.50-708488-ubuntu-18.04 driver doesn't work and the generic display driver installed with Ubuntu 18.04.1 LTS doesn't work either. I am only able to use recovery mode (NOMODESET) to run my system, and am still needing a solution. I'll try opening a request with AMD. My system processor is an AMD Ryzen 5 1600 six core, my graphics card is a Radeon RX570. Linux kernel supplied with Ubuntu is version 4.15.0-43-generic.

  • I disagree with you that this isn't an answer. It is an answer because the author of the question can install the missing graphics driver problem by selecting the root option in recovery mode – karel Jan 23 at 3:10
  • Hello Michael! Did you solve problems with amdgpu-pro? You may read my updated question in this thread. – Ubusm May 1 at 8:01
1

I have found partial solution for my problem. There was no need to install amdgpu, because it looks like they are already in the kernel. All I needed to do was to install Ubuntu and type this to grub: iommu=soft radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1

That way resolution was great and everithing worked great.

Exept one thing. I could not use second display (projector). It was working during uefi, but later during ubuntu starting up -> black screen.

SOlution: I changed amdgpu.dc=1 to amdgpu.dc=0 Only problem after this: Everithing is too contrast and bright. Colors are not natural.

How can I repair this?

xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DVI-D-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800     119.91    59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768     119.99    75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08 

(DVI-D-1 is projector and HDMI-A-0 is primary display)

  • you could look into AMD config options... anyways you should make this into a new question and also mark it as solution for curent question. – tatsu May 24 at 13:44
0

I solved this by installing 18.04 with a nvidia card. Then, installed the amd (amdgpu pro 18.50 in my case) drivers. Shutdown, remove nvidia card, and boot.

Hope this helps. :) AndyBurn

  • Thank you for an answer. I did this, It was you who suggested this temporary switch in one of previous answers. Thank for this. This way I was at least able to boot without nomodeset and to install amdpgu-pro succesfully. BUT, after installing this driver and restarting system, I get blackscreen after grub. I suspect that now there is some clash of drivers (installed drivers and kernel drivers maybe?). Is there any linei can add to grub (like I did with "nomodeset" before)? Or can I somehow change anything through grub? – Ubusm Apr 30 at 18:27
0

Part 2: You can also install using another PC. I used a G4400 Intel mobo (nvidia video) to install Ubuntu Mate 18.04 OS and amdgpu drivers before shutting down and moving the hdd (nvme) to my radeon 2400G. It worked like a charm. I used the same AMD drivers as you.

Remove your radeon card, and try nvidia, at least for the short term.

:)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.