0

I have Lenovo 330-15ich with i5 and gtx1050. But there's one problem. It seems like Ubuntu doesn't recognize my machine as a laptop. I don't have any battery indicator on the top panel, upower -d doesn't show any battery too. What's more, in settings there aren`t almost any options in power configuration. Also laptop doesn't suspend when I close the lid, despite I've chosen this option in Gnome Tweaks. I tried many suggestions from the internet, tried adding acpi=force or acpi_osi=Linux to my Grub configuration file without any results. So I really don't know what to do. Any help would be appreciated)

  • Run the command laptop-detect -v command (provided by the laptop-detect package). If the answer is that your system is NOT recognized as a laptop, then please file a bug report against the 'linux' package. Developers cannot fix what they do not know about. – user535733 Dec 30 '18 at 20:29
  • laptop-detect -v returns We're a notebook (chassis_type is 10) – Secret-guy Dec 31 '18 at 10:16
0

It would appear this laptop has many strange hardware IDs that cause the Linux kernel to not understand what hardware it's using:

On most vanilla Ubuntu systems for 18.10 you'll be using a kernel of 4.15 or older, and some are claiming that 4.18+ contain the changes to the Linux kernel to have these hardware IDs detected (note, it's not that Linux is missing the functionality to interface with the hardware, simply that the way the hardware is detected isn't matching various identifiers)

You can try using the Ubuntu Kernel Update Utility called ukuu to upgrade your kernel to 4.20:

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install ukuu

The run ukuu and select 4.20 to install.

More info on github.com/teejee2008/ukuu

  • 1
    I've successfully installed kernel 4.20, but, unfortunately, the result is the same( – Secret-guy Dec 31 '18 at 10:17
0

I didn't found any answer and tried to install elementary OS, which actually runs on kernel 4.15. Everything was great, except one - my laptop didn't suspend on lid close. So I tried to install newer kernel and battery was no more recognized. So, the answer is to install old kernel (for me the newest possible was 4.16.18). Unfortunately I didn't manage to resolve issue with suspending, looking for solution now. Also I reported it as Linux kernel bug.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.