4

Problem:

I've been running Ubuntu on my laptop for several months now and did not have this issue at all until today. My laptop has a nvidia gtx 960m graphics card which I thought may be the culprit.

Basically, every second or so, my screen will stutter. It's an incredibly regular interval like clockwork. It's not that noticeable normally, but if I watch any video it is incredibly irritating.

This issue is not due to performance, as my CPU usage sticks around 5% normally, and my RAM around 30%. GPU is typically around 10%. So none of these things is throttling to cause this.

I found several other posts related to mine, but none of them had solutions. These similar posts are here, here, here, and here. This one is also similar, but the poster found out it was a loose HDMI cord.

Solutions I've tried:

I've tried to figure out if there was something new I installed that could have caused this issue but every change I made of reverting recent installations hasn't helped.

I've tried purging all nvidia* packages and reinstalling them, deleting my old settings and going back to defaults for nvidia stuff. Unfortunately, none of these things have helped.

I have not been able to try just using my integrated intel gpu instead of my nvidia one, as my intel one can only handle resolutions of 600x900 or so and cannot really handle much. I thought that one idea might be to see if I could switch to just using my intel gpu, but that would not be a great solution. I found this similar issue and solution, but it doesn't seem that this solution would work for me. However in the limited time I did use my intel gpu, it seemed as if this issue was not present there.

I've also tried looking at my xorg settings and trying to change those, but that didn't seem to change anything either.

Personally, this is so aggravating that I feel if I cannot fix it I might just either reinstall Ubuntu or switch to a different operating system.

1
  • I had this issue on a brand new pc, with not very high specs. Found the following video: youtube.com/watch?v=9idhmMXGE5M Turned off my wifi as it suggested (I am connected wired) and it immediately solved the issue.
    – BazAbi
    May 1, 2020 at 10:52

4 Answers 4

6

I figured it out but I'm not entirely sure why this works!

It turned out that I had one of my gnome shell extensions (SystemMonitor) update values every second, and as soon as I turned this off it no longer had a stuttering issue. Why exactly that was the problem I am unsure, but turning it off fixed it.

3
  • I had to remove the default gnome shell extension (SystemMonitor) and restart the computer. No issues since then. This is the only answer that has resolved this issue. I now use Glance as the system monitor.
    – BCR
    Jan 7, 2019 at 16:05
  • A bug is filled here: bugs.launchpad.net/indicator-multiload/+bug/1878339 May 24, 2020 at 16:58
  • If you want a system monitor in the app indicators toolbar, using the Gnome Extension 'system-monitor' has been working fine for me! No stuttering on it's usage. Sep 21, 2020 at 22:04
1

Just to add to the list of solutions:

TLDR: Uninstall "System Load Indicator" if it's installed.

I'm on a freshly installed version of PopOS 20.10 (Ubuntu-based), a GeForce GT 710 GPU. Found this example which clearly showed that my video was stuttering regularly every second (https://codepen.io/0x04/pen/FHjnd). I thought it was the NVidia driver, so I switched to Nouveau, but the issue persisted. I then compared this to the animations on the recovery install that PopOS includes, which was smooth as silk. So I came to the conclusion that I had installed something, which was the cause. Turns out I had installed a utility called "System Load Indicator" which regularly samples CPU/GPU/RAM usage. Stopping that utility fixed everything.

0

Same issue of persistent video stuttering at exact intervals regardless of the video or how it was played (Youtube, Kodi, Netflix, etc.) The cause in my case was a Nvidia GPU Temp/Usage shell extension. Removing the extension immediately fixed the issue.

0

The stuttering is caused by the "Freq" frequency monitor only. The others does not cause this. So you can selectively disable only this and keep using the rest of the functions.

As mentioned above by Ben G turning off systemmonitor shell extension fixed the issue. I had this issue on different HW through several machines, through many Ubuntu versions.

I went to reenable the shell extension, regular stuttering immediately returned but when I unchecked both checkboxes (display and Show in menu) in the Freq tab it went away for good. The stuttering did not appear again. When I disable and reenable the extension (with unchecked boxes in Freq tab) it stutters once on enable, but not periodically. And other meters does not seems to cause the stuttering.

So I'm back using the System Monitor just disabled one meter causing this problem all this time.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.