0

I am running Ubuntu 18.04 on an old Acer Aspire e1-470p pc (with Intel HD Graphics 4000 Graphics processor) connected to a Viewsonic VX2703MH-LED monitor by HDMI.

I corrupted my boot options (probably by toggling UEFI and Secure settings in an attempt to boot Ubuntu Live ) leading to an inability to boot into either Win10 or my Ubuntu. I was able to partially resolve the issue by installing a new 18.04 version alongside my old 18.04.1. Previously my Viewsonic monitor was working with an HDMI connection to my Acer Aspire.

The details of my problems leading up to this point are here.

Old noob corrupted his dual boot, (bios legacy boot?). Any suggestions?

After installing Ubuntu alongside my previous installation, my PC boots well into the new install if the Viewsonic monitor is not connected, although still does not boot well into the old install. See above link for Train error.

However, if I boot with the Viewsonic monitor attached by HDMI cable, the GRUB interface appears on the monitor in large black and white screen. If I choose to boot, the screen monitor goes white with vertical stripes and then white with illegible black and white blocks of characters.

If I boot without the monitor attached, and wait until successful completion into Ubuntu, when I connect the Viewsonic monitor by HDMI nothing happens. My monitor does not detect any signal from the PC. (The monitor is working fine with my Raspberry Pi).

After boot

  • Thank you. Powered off, unplugged the monitor and disconnected HDMI cables. Waited 30. Reconnected. No change. – Pallama Dec 30 '18 at 1:19
  • I added a link to an image of the monitor after booting. – Pallama Dec 30 '18 at 1:32
0

It seems to me that 18.04 have problem with some Radeon HD card. So this may not be related to your monitor but Kernel Mode Setting. You can try to add "nomodeset" kernel parameter in Grub before boot to see if this helps.

  • Thanks. “ro nomodeset quiet splash” was already in the boot file for most recent kernel. I tried removing nomodeset, and monitor loaded the splash screen but then stopped when logo disappeared. Tried quiet splash nouveu.modeset=0, same thing. So I am getting the purple Ubuntu screen instead of the black and white gibberish but doesn’t complete booting – Pallama Dec 31 '18 at 3:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.