1

I am encountering an issue while trying to install Ubuntu 18.04 LTS on my new HP laptop...

Here are the characteristics of my computer : HP ProBook 470 G5 Core i5 8250U

  • RAM: 8 Go (1 x 8 GB) DDR4 SDRAM 2400 MHz
  • Graphical cards : Intel UHD Graphics 620 & NVIDIA GeForce 930MX
  • Video memory : 2 Go DDR3 SDRAM
  • Processor Intel Core i5 (8th generation) 8250U - 1.6 GHz

The computer freezes when booting on the Ubuntu Live CD (I have also tried the Xubuntu CD), generally after the mouse has appeared.

Generally, the computer show a message saying that the nouveau module encountered an error.

I tried to edit grub boot options, replacing splash quiet with nouveau.nomodeset=0but it did not improve anything, as nomodeset.

I also tried to clone a working installation of Ubuntu from another computer using Clonezilla but the system freezes at logon screen and the logs says that gdm could not start.

What could I do to install Ubuntu on this computer ? Is there any module I should disable / enable to get my computer working ?

Thank you in advance !

1

One of my friend told my this issue could come from nVidia Optimus, a technology from nVidia that tries to improve battery life by switching between two graphicals cards (A nVidia card and an Intel Graphic HD card for example). This allowed to me create the following procedure to get Ubuntu 18.04 LTS up and running on my computer :

Ubuntu HP ProBook 470 G5

It might be tough to get Ubuntu working on this laptop...

Base Setup

  • Disable secure boot and enable legacy support
  • Install Ubuntu server (NOT LIVE EDITION !!)
  • Install nvidia-driver-390 x11-xserver-utils xinit
  • Create and edit file /usr/share/X11/xorg.conf.d/50-custom.conf

    Section "Module"
      Load "modesetting"
    EndSection
    
    Section "Device"
      Identifier "nvidia"
      Driver "nvidia"
      BusID "1:0:0:"
      Option "AllowEmptyInitialConfiguration"
    EndSection
    

Install desktop

XFCE4

  • sudo apt install xfce4

Ubuntu Desktop

  • sudo apt install ubuntu-desktop

Configure Lightdm

  • sudo apt install lightdm

XFCE 4

  • Create the file /etc/lightdm/lightdm.conf.d/50-session.conf adding the following content:

    [SeatDefaults]
    user-session=xfce
    

Ubuntu Desktop

  • Create the file /etc/lightdm/lightdm.conf.d/50-session.conf adding the following content:

    [SeatDefaults]
    user-session=ubuntu
    

Other sessions

  • Find the required session using ls /usr/share/xsessions/{SESSION_NAME}.desktop
  • Create the file /etc/lightdm/lightdm.conf.d/50-session.conf adding the following content:

    [SeatDefaults]
    user-session={SESSION_NAME}
    

Fix GPU drivers

Basic usage with xinit

  • Add the following lines at the begining of .xinitrc :

    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto
    

LightDM Display Manager configuration

  • Create the file /etc/lightdm/display_setup.sh with the following content :

    #!/bin/sh
    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto
    
  • Make the script executable : chmod +x /etc/lightdm/display_setup.sh

  • Configure lightdm to run the script :

    [Seat:*]
    display-setup-script=/etc/lightdm/display_setup.sh
    

Check your computer is using nVidia card

You can check nVidia card is being used by issuing the following commands into a terminal: sudo apt install mesa-utils glxinfo | grep NVIDIA

Reference

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.