I have Ubuntu 18 and Windows 10 installed in dual boot on my machine.

I now have to do some tuning on the disk partitions and wanted to do it with the gparted available directly on the Ubuntu live USB.

The problem is that I cannot manage to get the USB booting.
I unfortunately do not have access to the BIOS. Before I installed Windows, GRUB was directly booting the USB when I typed exit on the grub> command line which is how I could install it, but now when I do exit at the GRUB command line it boots directly to Windows 10.

How can I boot to the live USB from GRUB?

I tried the solution posted in How to change boot order in grub2 to include bootable USB? and also mentioned in this blog post and it did not work.

To give more information:
it is a UEFI boot

here are the information about the USB I get using
lsblk -o name,mountpoint,label,size,uuid

NAME        MOUNTPOINT                 LABEL         SIZE UUID
sdb                                                  7.2G 
└─sdb1      /media/rayan/UBUNTU 18_0   UBUNTU 18_0   7.2G 466D-342D

closed as off-topic by Fabby, guiverc, Eric Carvalho, vidarlo, George Udosen Jan 2 at 6:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Fabby, guiverc, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Welcome to Ask Ubuntu! :-) Unfortunately, the boot process before Ubuntu is run is a feature of the BIOS / UEFI firmware, so you need to get that sorted first as those questions are off-topic here, but on-topic over at superuser.com, a sister site to Ask Ubuntu. – Fabby Dec 29 '18 at 12:27
  • 1
    Try configfile entry here, example uses your label, so make sure it has a label. askubuntu.com/questions/344125/… Or use a chain type entry to /EFI/Boot/bootx64.efi. Assumes newer UEFI boot, not old BIOS boot. – oldfred Dec 29 '18 at 15:02
  • @oldfred I think I tried this too. But did not try with a chain type. It is a UEFI boot btw. What would be the difference for a chain type entry? – user3544665 Dec 30 '18 at 5:58
  • 2

Thanks to @oldfred I found a solution by using this one

I had to modify it for my case like this:

menuentry "Ubuntu 18 live" {
    search --set=root --label "UBUNTU 18_0"
    configfile /boot/grub/grub.cfg 

and it worked perfectly


Booting Full Install Flash Drive from Internal Grub

What works for me is to:

  • Boot the computer from the internal drive.

  • Plug in the Full install USB drive.

  • Open Terminal and run:

    sudo update grub

  • Next boot, Ubuntu from the USB drive, should appear as a grub option.

Note: Running update-grub automatically adds the new menuentry(s) to 30_os-prober. The menuentry(s) can be cut and pasted to 40_custom if desired.

Not the answer you're looking for? Browse other questions tagged or ask your own question.