-1

My current command line results:

localhost / # whoami
root
localhost / # pwd
/
localhost / # sl
bash: sl: command not found
localhost / # sudo apt install sl
sudo: apt: command not found
localhost / #

I tried to run sl command, but I got this error message.

bash: sl: command not found. 

I tried to run sudo apt install sl but I got this error message:

sudo: apt: command not found.

closed as off-topic by karel, N0rbert, Eric Carvalho, Charles Green, Zanna Dec 29 '18 at 18:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – N0rbert, Charles Green, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please don't include pictures of text, add the text to your question. You haven't told us what Ubuntu (or OS) release you are using? I'd suggest whereis apt to see if it's present, and then check your $PATH – guiverc Dec 29 '18 at 2:27
  • 2
    Which distribution is this? – Chai T. Rex Dec 29 '18 at 2:58
  • Why are you using sudo at a root prompt? – user535733 Dec 29 '18 at 3:54
  • 1
    Possible duplicate of sudo: command not found – karel Dec 29 '18 at 5:16
  • You have tagged kali - do you have kali or katoolin installed? – Charles Green Dec 29 '18 at 17:08
0

Since you're root, you should not use sudo in your command. Sudo is a way of temporarily giving yourself root permissions, which you don't need in this scenario since you're already root. Just try apt install sl.

If that doesn't work, I would need more details to fix this.

  • Thank you for clarifying the root permissions. I ran the command apt install sl. My return was, -bash: apt: command not found. I ran $PATH next and this was the return, -bash: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin: No such file or directory – APhoenix Dec 31 '18 at 3:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.