0

I'm currently trying to do a fresh install of Ubuntu 18.04 LTS from a USB 2.0 on a new Windows 10 machine (want to replace the OS). The main issue I'm encountering is that during install, eventually I hit BusyBox with the error

(initramfs) Unable to find a medium containing a live file system

I'm convinced that this is an issue with my USB ports shutting down, specifically only during the installation of Ubuntu.

Full description

  • I created the live USB with Rufus (following Ubuntu's tutorial). I verified the integrity of the download.
  • In BIOS, I disabled Secure Boot, and I'm booting with UEFI priority. I made sure that all the USB options in BIOS are set as "Enabled".
  • When booting the USB with Ubuntu on it, I hit a black screen after the GNU Grub screen (Try or Install Ubuntu). I bypassed this by adding nomodeset acpi=off and nolapic parameters (following this guide).

Other Symptoms

My USB ports seem to work fine when I'm in Windows. I reach GNU Grub and the purple Ubuntu screen, so it seems like the USB is detected when booting. However, the USB stops flashing whenever the black screen with the boot errors/firmware bugs pop up. I have a LED mouse attached to another USB port during the process and the LED turns off here too. From here, I reach the purple Ubuntu screen, and then the BusyBox with the initramfs error.

The live USB works fine on other machines.

What I've tried

  • USB 3.0 in 3.0 port; USB 2.0 in 2.0 port; USB 3.0 in 2.0 port; USB 2.0 in 3.0 port
  • Using an older version of Ubuntu
  • Unplugging and replugging USB during the Ubuntu purple screen (via here)
  • Changing boot order
  • Booting from legacy
  • Adding usbcore.autosuspend_delay_ms=-1 to the boot options
  • Trying both "Try before installing" and "Install Ubuntu"
  • Creating the USB with LinuxLive and Unetbootin

System and Hardware

I'm trying on a new Lenovo Thinkpad E585 with

  • Motherboard: Lenovo KV20CVTO1WW
  • CPU: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx

There is no CD/DVD Drive. I thought about using an external DVD drive, but I would expect the same result, since it connects via USB. Am aware that this is a frequently encountered issues, but no fix has worked for me so far. Any help much appreciated.

Thanks for your time.

3 Answers 3

0

Solution

It turns out some of the boot options probably interfered with the USB ports' functionality during install. I believe apci=off may have controlled some power settings.

What worked for me was booting with the options nomodeset and noapic. I needed the nomodeset to get past the graphical problems.

0

The above answer works. put the USB stick in another PC, go to boot folder and open grub.cfg with notepad, sublime or another editor. edit the grub line and add the apci=off and the noapic before the "quiet" and leave all the rest same. save the file. put the pendrive back to the PC/Notebook Go to bios, reset to factory defaults, because i know you broke all the bios trying and error for a solution, (keep uefi enabled by default ubuntu 18. works with that enabled) start the computer press f12 or f8 or whatever button for boot menu. In the menu you probably will have 2 sections, Legacy and UEFI, go to UEFI section and select boot with your pendrive. NOW WAIT and ubuntu live will run normally. Finish your installation if you need it.

NOTE: After you install ubuntu, if you remove the stick and restart the computer, maybe like me with a Dell laptop, you will encounter a no boot disk error, to solve, start with boot menu again (without the pendrive) and you will find 2 uefi partitions one with the name "ubuntu" and in my case Toshiba disk partition 1 Use Ubuntu option in the UEFI section to boot, you can fix it in the bios after.

Have a nice day!

1
  • This does not fix the problem for me. Feb 2, 2020 at 20:15
0

For anyone who encountered this error message, I was having "No-irq handler" error at first, then this error. I solved both these errors with adding only "noapic", not including "apci=off" and "pci=nomsi,noaer", booted in safe graphics mode. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.