1

I attempted to install VirtualBox but remembered half way through that the last time I did this it failed when doing something with UEFI Secure Boot and I wasn't able to boot to Ubuntu after restarting my laptop.

After remembering this I exited out of the install half way through to prevent it happening again.

Now, everytime I attempt to use apt to install a package I get the following error:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Running the command listed attempts to uninstall virtualbox with the following output:

Setting up virtualbox-dkms (5.2.18-dfsg-2~ubuntu18.04.1) ...
Removing old virtualbox-5.2.18 DKMS files...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.2.18
Kernel:  4.15.0-39-generic (x86_64)
-------------------------------------

Status: This module version was INACTIVE for this kernel.
depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.2.18
completely from the DKMS tree.
------------------------------
Done.
Loading new virtualbox-5.2.18 DKMS files...
Building for 4.15.0-39-generic
Building initial module for 4.15.0-39-generic

This then loads the following familiar UEFI screen attached below:

Configuring Secure Boot

Problem is I'm scared of continuing that screen incase it fails again and borks my booting process.

How can I fix the dpkg error without having to continue with the UEFI configuration process?

Additional Info:

~ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic

~ sudo apt list | grep virtualbox
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

boinc-virtualbox/bionic-updates 7.9.3+dfsg-5ubuntu2 amd64
unity-scope-virtualbox/bionic,bionic 0.1+13.10.20130723-0ubuntu1 all
virtualbox/bionic-updates,now 5.2.18-dfsg-2~ubuntu18.04.1 amd64 [installed]
virtualbox-dkms/bionic-updates,bionic-updates,now 5.2.18-dfsg-2~ubuntu18.04.1 all [installed,automatic]
virtualbox-ext-pack/bionic-updates,bionic-updates 5.2.18-1~ubuntu18.04.1 all
virtualbox-guest-additions-iso/bionic-updates,bionic-updates 5.2.18-1~ubuntu18.04.1 all
virtualbox-guest-dkms/bionic-updates,bionic-updates 5.2.18-dfsg-2~ubuntu18.04.1 all
virtualbox-guest-dkms-hwe/bionic-updates,bionic-updates 5.2.18-dfsg-3~ubuntu18.04.1 all
virtualbox-guest-source/bionic-updates,bionic-updates 5.2.18-dfsg-2~ubuntu18.04.1 all
virtualbox-guest-source-hwe/bionic-updates,bionic-updates 5.2.18-dfsg-3~ubuntu18.04.1 all
virtualbox-guest-utils/bionic-updates 5.2.18-dfsg-2~ubuntu18.04.1 amd64
virtualbox-guest-utils-hwe/bionic-updates 5.2.18-dfsg-3~ubuntu18.04.1 amd64
virtualbox-guest-x11/bionic-updates 5.2.18-dfsg-2~ubuntu18.04.1 amd64
virtualbox-guest-x11-hwe/bionic-updates 5.2.18-dfsg-3~ubuntu18.04.1 amd64
virtualbox-qt/bionic-updates,now 5.2.18-dfsg-2~ubuntu18.04.1 amd64 [installed,automatic]
virtualbox-source/bionic-updates,bionic-updates 5.2.18-dfsg-2~ubuntu18.04.1 all

~ apt-get --help
apt 1.6.6 (amd64)

My knowledge of package management in Ubuntu is limited and I would appreciate any help.

  • Why don't you turn off secure boot and proceed? – George Udosen Dec 28 '18 at 16:26
  • Not thought of that. It might be worth mentioning that it is a dual Win 10 / Ubuntu boot and I installed windows first. I'll have a go now. – Charlie Dec 28 '18 at 16:32
  • Please avoid running with secure boot as Windows plays dirty in some if not all cases! – George Udosen Dec 28 '18 at 16:45
  • 1
    Not the first problem it has caused, doubt it'll be the last. Thanks again. – Charlie Dec 28 '18 at 16:48
0

Problem resolved by turning off Secure Boot in BIOS settings, restarting and running sudo dpkg --configure -a.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.