2

I'm currently using Ubuntu 18.10 on a machine with Nvidia OPTIMUS (GeForce 650M on Samsung NP550P5C-S01IN). Currently for Nvidia, I'm using nvidia-driver-390, though current selected GPU is Intel.

My idle CPU temperate resides in the range of 68C to 75C (154F to 167F) which is too hot. The weird thing is that the fan runs at really low speed. I know the fan can run faster because during GRUB screen, before selecting the OS, the fan spins much much faster (can even hear it).

Yesterday, I even cleaned up the fans and replaced thermal compound, which only helped with lowering like 2-3C.

The fan does not have speed control but in Windows 7, I did used to have the option to run the fan 'silently' (i.e, slower).

Hope I can get some help with this.

0

Depending on the laptop model your fan may be controllable via software, such as the fancontrol package, pwmconfig or by directly putting values into the /sys/classes/thermal/cooling_device*/cur_state values. However, testing with the latter it seems these values didn't cause the fans to get turned on. My understanding is that these are part of the ACPI subsystem and many vendors expose some details in the "tables" but don't honor the writes - so the fans don't actually get turned on.

For some vendor specific laptops (Dell) there are utilities that make specific requests to the fan controllers that do work, but I am not aware of any that do this for Samsung devices.

I did used to have the option to run the fan 'silently' (i.e, slower).

It's possible that by setting certain power configurations as you did in Windows is how the fan controller is determining when to turn on and off. In Linux these are often known as "governors" and can be modified using the cpupower command.

Another interesting side note is that if you "soft" shutdown from Windows sometimes it leaves the fan controller in a strange state, with some users reporting that their fan works in Linux when they use a full shutdown followed up with a real power button press when rebooting: Source

  • as per pwmconfig," /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed" – about 99 ninjas Dec 27 '18 at 12:07
0

Remove pwmconfig, and any values you placed into /sys/classes/thermal/cooling_device*/cur_state.

Install and configure thermald. This will help keep your computer cooler.

If fan control isn't fast enough, you may need to customize /etc/thermald/thermal-conf.xml.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.