0

I am not able to install any software in my laptop which is running Ubuntu 16.04.

Below are my logs:

lenovo@vvdn:~$ sudo apt-get install meld 
[sudo] password for lenovo: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.15.0-30 linux-headers-4.15.0-30-generic linux-headers-4.15.0-33 linux-headers-4.15.0-33-generic linux-headers-4.15.0-38
  linux-headers-4.15.0-38-generic linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic linux-headers-4.4.0-139
  linux-headers-4.4.0-139-generic linux-image-4.15.0-30-generic linux-image-4.15.0-33-generic linux-image-4.15.0-38-generic
  linux-image-4.4.0-134-generic linux-image-4.4.0-139-generic linux-image-extra-4.4.0-134-generic linux-image-extra-4.4.0-139-generic
  linux-modules-4.15.0-30-generic linux-modules-4.15.0-33-generic linux-modules-4.15.0-38-generic linux-modules-extra-4.15.0-33-generic
  linux-modules-extra-4.15.0-38-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  python python-cairo python-gi python-gi-cairo
Suggested packages:
  python-doc python-tk
The following NEW packages will be installed:
  meld python python-cairo python-gi python-gi-cairo
0 upgraded, 5 newly installed, 0 to remove and 73 not upgraded.
1 not fully installed or removed.
Need to get 0 B/835 kB of archives.
After this operation, 4,523 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up python-minimal (2.7.12-1~16.04) ...
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in 
    main()
  File "/usr/lib/python2.7/site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 272, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 247, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 237, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 582, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 528, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 412, in _init_posix
    from _sysconfigdata import build_time_vars
  File "/usr/lib/python2.7/_sysconfigdata.py", line 6, in 
    from _sysconfigdata_nd import *
ImportError: No module named _sysconfigdata_nd
dpkg: error processing package python-minimal (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 python-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- Logs of 'sudo apt autoremove' command:

lenovo@vvdn:~$ sudo apt autoremove
[sudo] password for lenovo: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-4.15.0-30 linux-headers-4.15.0-30-generic linux-headers-4.15.0-33 linux-headers-4.15.0-33-generic linux-headers-4.15.0-38
  linux-headers-4.15.0-38-generic linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic linux-headers-4.4.0-139
  linux-headers-4.4.0-139-generic linux-image-4.15.0-30-generic linux-image-4.15.0-33-generic linux-image-4.15.0-38-generic
  linux-image-4.4.0-134-generic linux-image-4.4.0-139-generic linux-image-extra-4.4.0-134-generic linux-image-extra-4.4.0-139-generic
  linux-modules-4.15.0-30-generic linux-modules-4.15.0-33-generic linux-modules-4.15.0-38-generic linux-modules-extra-4.15.0-33-generic
  linux-modules-extra-4.15.0-38-generic
0 upgraded, 0 newly installed, 22 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 1,442 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 483487 files and directories currently installed.)
Removing linux-headers-4.15.0-30-generic (4.15.0-30.32~16.04.1) ...
Removing linux-headers-4.15.0-30 (4.15.0-30.32~16.04.1) ...
Removing linux-headers-4.15.0-33-generic (4.15.0-33.36~16.04.1) ...
Removing linux-headers-4.15.0-33 (4.15.0-33.36~16.04.1) ...
Removing linux-headers-4.15.0-38-generic (4.15.0-38.41~16.04.1) ...
Removing linux-headers-4.15.0-38 (4.15.0-38.41~16.04.1) ...
Removing linux-headers-4.4.0-134-generic (4.4.0-134.160) ...
Removing linux-headers-4.4.0-134 (4.4.0-134.160) ...
Removing linux-headers-4.4.0-139-generic (4.4.0-139.165) ...
Removing linux-headers-4.4.0-139 (4.4.0-139.165) ...
Removing linux-image-4.15.0-30-generic (4.15.0-30.32~16.04.1) ...
/etc/kernel/prerm.d/dkms:
dkms: removing: virtualbox 5.1.38 (4.15.0-30-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.1.38
Kernel:  4.15.0-30-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-30-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-30-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-30-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-30-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod......

DKMS: uninstall completed.
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-30-generic
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.15.0-38-generic
Found initrd image: /boot/initrd.img-4.15.0-38-generic
Found linux image: /boot/vmlinuz-4.15.0-33-generic
Found initrd image: /boot/initrd.img-4.15.0-33-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found linux image: /boot/vmlinuz-4.4.0-134-generic
Found initrd image: /boot/initrd.img-4.4.0-134-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-modules-extra-4.15.0-33-generic (4.15.0-33.36~16.04.1) ...
Removing linux-image-4.15.0-33-generic (4.15.0-33.36~16.04.1) ...
/etc/kernel/prerm.d/dkms:
dkms: removing: virtualbox 5.1.38 (4.15.0-33-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.1.38
Kernel:  4.15.0-33-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-33-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-33-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-33-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-33-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-33-generic
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.15.0-38-generic
Found initrd image: /boot/initrd.img-4.15.0-38-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found linux image: /boot/vmlinuz-4.4.0-134-generic
Found initrd image: /boot/initrd.img-4.4.0-134-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-modules-extra-4.15.0-38-generic (4.15.0-38.41~16.04.1) ...
Removing linux-image-4.15.0-38-generic (4.15.0-38.41~16.04.1) ...
/etc/kernel/prerm.d/dkms:
dkms: removing: virtualbox 5.1.38 (4.15.0-38-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.1.38
Kernel:  4.15.0-38-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-38-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-38-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-38-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.15.0-38-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-38-generic
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found linux image: /boot/vmlinuz-4.4.0-134-generic
Found initrd image: /boot/initrd.img-4.4.0-134-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-image-extra-4.4.0-134-generic (4.4.0-134.160) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
Error! Your kernel headers for kernel 4.4.0-134-generic cannot be found.
Please install the linux-headers-4.4.0-134-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-134-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found linux image: /boot/vmlinuz-4.4.0-134-generic
Found initrd image: /boot/initrd.img-4.4.0-134-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-image-4.4.0-134-generic (4.4.0-134.160) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-134-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-134-generic /boot/vmlinuz-4.4.0-134-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-image-extra-4.4.0-139-generic (4.4.0-139.165) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found linux image: /boot/vmlinuz-4.4.0-139-generic
Found initrd image: /boot/initrd.img-4.4.0-139-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done
Removing linux-image-4.4.0-139-generic (4.4.0-139.165) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
dkms: removing: virtualbox 5.1.38 (4.4.0-139-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.1.38
Kernel:  4.4.0-139-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-139-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-139-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-139-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-139-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-139-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-139-generic /boot/vmlinuz-4.4.0-139-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-43-generic
Found initrd image: /boot/initrd.img-4.15.0-43-generic
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.4.0-141-generic    
Found initrd image: /boot/initrd.img-4.4.0-141-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
done    
Removing linux-modules-4.15.0-30-generic (4.15.0-30.32~16.04.1) ...
Removing linux-modules-4.15.0-33-generic (4.15.0-33.36~16.04.1) ...
Removing linux-modules-4.15.0-38-generic (4.15.0-38.41~16.04.1) ...
Setting up python-minimal (2.7.12-1~16.04) ...
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in <module>
    main()
  File "/usr/lib/python2.7/site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 272, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 247, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 237, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 582, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 528, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 412, in _init_posix
    from _sysconfigdata import build_time_vars
  File "/usr/lib/python2.7/_sysconfigdata.py", line 6, in <module>
    from _sysconfigdata_nd import *
ImportError: No module named _sysconfigdata_nd
dpkg: error processing package python-minimal (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 python-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)
lenovo@vvdn:~$ 
lenovo@vvdn:~$ 

-- Logs of 'sudo apt install --reinstall python-minimal' command:

lenovo@vvdn:~$ 
lenovo@vvdn:~$ sudo apt install --reinstall python-minimal
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 1 not upgraded.
Need to get 28.1 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://in.archive.ubuntu.com/ubuntu xenial-updates/main amd64 python-minimal amd64 2.7.12-1~16.04 [28.1 kB]
Fetched 28.1 kB in 16s (1,676 B/s)        
dpkg: warning: files list file for package 'python-minimal' missing; assuming package has no files currently installed
(Reading database ... 317140 files and directories currently installed.)
Preparing to unpack .../python-minimal_2.7.12-1~16.04_amd64.deb ...
Unpacking python-minimal (2.7.12-1~16.04) over (2.7.12-1~16.04) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python-minimal (2.7.12-1~16.04) ...
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in <module>
    main()
  File "/usr/lib/python2.7/site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 272, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 247, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 237, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 582, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 528, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 412, in _init_posix
    from _sysconfigdata import build_time_vars
  File "/usr/lib/python2.7/_sysconfigdata.py", line 6, in <module>
    from _sysconfigdata_nd import *
ImportError: No module named _sysconfigdata_nd
dpkg: error processing package python-minimal (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 python-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)
lenovo@vvdn:~$ 
lenovo@vvdn:~$    

-- Logs of 'sudo apt-get update' and 'sudo apt-get upgrade' commands:

lenovo@vvdn:~$ sudo apt-get update
[sudo] password for lenovo: 
Hit:1 https://repo.skype.com/deb stable InRelease                                                                                             
Hit:2 https://download.sublimetext.com apt/stable/     InRelease                                                                                  
Hit:3 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu xenial     InRelease                                                                         
Hit:4 http://in.archive.ubuntu.com/ubuntu xenial     InRelease                                                                                    
Ign:5 http://archive.ubuntu.com/ubuntu trusty     InRelease                                                                                       
Ign:6 http://old-releases.ubuntu.com/ubuntu raring     InRelease                                                                                  
Ign:7 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                  
Hit:8 http://apt.postgresql.org/pub/repos/apt xenial-pgdg InRelease                                                                           
Hit:9 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                            
Hit:10 http://archive.ubuntu.com/ubuntu trusty     Release                                                                                            
Hit:11 http://old-releases.ubuntu.com/ubuntu raring Release                                                                                   
Hit:12 http://dl.google.com/linux/chrome/deb stable Release                                                                               
Hit:13 http://package.perforce.com/apt/ubuntu trusty InRelease                                                       
Hit:14 http://in.archive.ubuntu.com/ubuntu xenial-backports InRelease   
Hit:15 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial InRelease
Hit:18 http://in.archive.ubuntu.com/ubuntu xenial-security InRelease                                
Hit:20 http://ppa.launchpad.net/mc3man/xerus-media/ubuntu xenial InRelease                        
Hit:21 http://ppa.launchpad.net/team-gcc-arm-embedded/ppa/ubuntu xenial InRelease
Reading package lists... Done 
lenovo@vvdn:~$ 
lenovo@vvdn:~$ 
lenovo@vvdn:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  ubuntu-minimal
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
lenovo@vvdn:~$     
  • @Kulfy . I don't understnad how can he reinstall, because in the first place he is getting error while installing. – cloud.009 Dec 27 '18 at 20:42
  • @Kulfy what you said is exactly correct, but i have been through the exact error while using ubuntu..I didn't purged it though, i just removed the file from dpkg info and everything ran fine afterwards. Also i didn't advice him to purge anything, as you can see it. – cloud.009 Dec 28 '18 at 10:42
  • @Kulfy How did we know the one who asked question is not answering anything.. haha :D – cloud.009 Dec 28 '18 at 17:10
  • @Kulfy i tried 'sudo apt install --reinstall python-minimal' command and getting the errors. detailed console logs i have added in my post – Bhavin Dec 29 '18 at 5:27
0

You can just remove the entry from dpkg status,to do that go to vim /var/lib/dpkg/status and remove the error creating files. Then just configure your dpkg using sudo dpkg --configure -a then use sudo apt-get -f install , then your installation will get resumed where it had stopped. Hope this helps you with your problem.

  • Else you can use this – cloud.009 Dec 27 '18 at 10:23
  • Hi cloud.009, I not understand which entry i have to remove. so from the logs can you please suggest me which entry i have to remove from vim /var/lib/dpkg/status. – Bhavin Dec 27 '18 at 11:45
  • Use 'sudo apt autoremove' – cloud.009 Dec 27 '18 at 12:58
  • Hi cloud.009, i have tried 'sudo apt autoremove' command but i am getting error. i have added detailed console logs of 'sudo apt autoremove' command in my post. – Bhavin Dec 27 '18 at 14:05
  • 'ls -l /var/lib/dpkg/info | grep -i python-minimal'. Then remove it using 'sudo mv /var/lib/dpkg/info/python-minimal.* /tmp'. Hope this will help you. – cloud.009 Dec 27 '18 at 20:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.