I am trying to connect to the internet on my mobile phone through tethering. I cannot seem to do this through any of the three methods: bluetooth, wifi hotspot, or usb.

I am using Ubuntu 18.04 and a Huawei Nova.

The phone shows that a device is connected when using bluetooth and wifi tethering but Ubuntu cannot seem to connect. I keep getting an Activation failed message.

I am using the same laptop that I used Ubuntu 16.04 on and tethering was working out of the box. The Ubuntu 16.04 was a regular install compared to this (minimal) installation. Might this have to do with the minimal installation? Some package might not be installed?

Update: Following this post I set the configuration file similarly except for the domain which I left commented. dnsmasq starts when I disable and stop systemd-resolved but the problem persists.

  • Do you have dnsmasq installed and configured? dpkg -l dnsmasq – heynnema Dec 26 '18 at 16:40
  • No it was not installed. I installed it however it still fails to connect. Moreover, during booting of the system there's a [Failed] Failed to start dnsmas. – user10853 Dec 27 '18 at 8:55
  • What kind of configuration? – user10853 Dec 27 '18 at 8:57
  • /etc/dnsmasq.conf, and you can man dnsmasq. – heynnema Dec 27 '18 at 18:06
  • Yes it is installed. The config file is the default. It is commented out. I will update my question with the lines I commented out and edited. – user10853 Dec 30 '18 at 14:26
  1. after installing dnsmasq, you need to configure it. Check /etc/dnsmasq.conf.

  2. you can temporarily try setting a unused static IP/DNS addresses in the phone, and see if you can reach the Internet then.

  3. if you're running both dnsmasq and systemd-resolved...

Do a ps auxc | grep -i dns and ps auxc | grep -i resolv and look for dnsmasq and systemd-resolved, and if both are running, you need to disable the DNS part of systemd-resolved by editing /etc/systemd/resolved.conf and...




  • This entry does not exist in the commented out content. Adding it to the end results in an error about it. – user10853 Dec 30 '18 at 14:25
  • @user10853 what file are you editing? – heynnema Dec 30 '18 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.