0

I had a working install of Kubuntu 18.04 and tried to install Lubuntu 18.10 on another partition (something I've done successfully before, when transitioning from Ubuntu to Kubuntu about a year ago). In the Lubuntu LiveUSB installer, I chose the option to replace an existing partition. the install failed with the following error message:

INSTALLATION FAILED

Boost.python error in job "bootloader"

Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --forcd' returned non-zero exit status 1

Installing for x86_64-efi platform. Could not delete variable: interrupted system call. Grub-install:error:efibootmgr failed to register the boot entry: block device required.

I launched boot-repair. After making me manually reinstall grub2, it failed with its own error message. (report is at paste.ubuntu.com/p/thSvKrcPZB) I tried with several install configuration. I also tried with Ubuntu 18.04. In the end I tried a brand new install by creating a whole new GPT table. I still got the same error message (I tried with or without creating a FAT32 boot partition mounted at /boot/efi).

What could possibly be the problem ?

Another thing to note: my EFI "bios" is set to Secure Boot = disabled and Legacy mode = disabled. Actually I can't set Legacy mode to "enabled" and make it stick: if I do it and reboot, the Legacy mode setting will revert back to "disabled".

EDIT:

  • I tried a bios update following the procedure described on the HP website. It failed after a couple of write/verify cycles. The logfile ends with the very ominous "Failed RetryBlocks Call Status (Device Error)".

  • I can manually boot into the newly installed Lubuntu 18.10 by pressing F9 at startup and then choosing to boot from EFI file: /EFI/ubuntu/shimx64.efi (this is not the only file that I can boot from though)

  • the EFI boot order is set to the following (which I can change, but the changes won't be saved at next reboot): USB / OS boot manager / Internal CD/DVD / USB CD/DVD / Network adapter

  • even when I choose the option to "load factory settings" in the EFI bios, no change will actually be saved at the next reboot

  • the F9 "manual boot" menu has the other following options, which all lead to the computer saying "The selected boot device failed" and freezing: "ubuntu"/"internal HD"/"CD/DVD". As I said before, only "boot from EFI file" allows me to boot.

  • here's the very latest boot-repair report: https://paste.ubuntu.com/p/qPkDdvNdbQ/ (again it ended with a failure) (do not mind the entries concerning the /dev/sdb disk, it's an external hard drive)

  • My computer is a HP Pavilion 14-n249nf, bought in 2014.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.