0

Sorry if the title is a little confusing. I'm trying to get rosserial installed as to allow communication between ROS and my arduino. I was following the guide and nothing would install rosserial aside from the catkin method and saved in my catkin_ws folder in my home tab. The next step was to run -

 cd <sketchbook>/libraries

 rm -rf ros_lib

 rosrun rosserial_arduino make_libraries.py

Running these commands in either home/usr/arduino-1.8.8/libraries or home/usr/arduino/libraries doesn't work either, it just throws at me 'rospack Error: package 'rosserial_arduino' not found'. I even manually moved the rosserial_arduino file (the one with make_libraries.py) and tried again but still doesn't work. I'm new to this so i've exhausted everything I can think of but hope someone a bit more savvy can help! Thanks.

0

Got it working by moving all the rosserial files to trash and then running the sudo apt-get install method. I did try it first but it just wouldn't work, but did now for whatever reason...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.