0

I had no problems doing this in Unity by the way. The problem started with the 18.04 when I started using the built in Gnome docker.

I have three windows apps that I have the user to run through clicking an icon. The launcher I created successfully runs a script with the following content:

export LANG=sl.SI.utf8 && wine "somepath/asp.exe"

I don't think the actual content of the script is a problem however I can only add launcher links with icons to the desktop area only and NOT the dock. If I run the application adding it to favourites does not work. When the app is opened a default icon appears in the dock Clicking add to favourites does keep that icon there but it does not work when clicked. I get the hour glass for a few seconds and then nothing happens.

I have tried manually creating .desktop files in "~/.local/share/applications". Does not seem applicable for the Gnome dock though.

Is this a bug/limitation in Gnome?

  • Yes, I might have not been specific on the terminology but I will excuse myself due to the change to Gnome. I think they call it the Gnome dock. I found an article saying that the nautilus will e deprecating running binary apps directly with double clicking but I don't think this applies in this problem. – Martin McDowell Dec 25 '18 at 19:54
  • If you sure that you mean Gnome Dock, please edit your question. Comments are often overlooked by the folks who know the answers. – user535733 Dec 25 '18 at 20:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.