0

I click Software & Updates, then the Updates tab.
I click the dropdown for "Notify me of a new Ubuntu version:" and try to pick "For any new version." The option does NOT change from "For long-term support versions".

I click Revert, nothing happens.
I click close and get a popup that says

The information about available software is out-of-date. To install software and updates from newly added or changed sources, you have to reload the information about available software. You need a working internet connection to continue.

I have a working internet connection.
My two options are Reload and close. Close closes Software and Updates. Reload gives a popup that says

You are not allowed to perform this action. You dont have the required privileges to perform this action.

I click details and it says

org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name' , {'name': ':1.109'}): org.debian.apt.update-cache
0

You have to use sudo whenever it says you dont have required privilages..Open your terminal and type sudo gnome-software One more thing you can do is to use your terminal to download any packages you want, all you have to do is

sudo apt-get install <name of package/software>

To update and upgrade your ubuntu use

sudo apt-get update && sudo apt-get upgrade

Hope this helps you.

  • So did all that stuff which worked. I opened up Software Updater . It checked then the same "You are not allowed to perform this action" popup came up. I click close, then get another popup that says my software is up to date, but 18.04.1 LTS is available (you have 16.04). If I click "Upgrade..." it goes away and nothing happens. If I click "Settings..." it loops back into my original problem. If I click "OK" it just goes away – Okamisomething Dec 25 '18 at 8:26
  • try using your terminal to upgrade if you want to, but first make backup of all your files and type type 'do-release-upgrade' in your terminal..If you just want to install some packages use the 'sudo apt-get <package-name> – cloud.009 Dec 25 '18 at 8:29
  • I did the release command and now it's doing its thing. If anything comes up, I'll let you know. Thank you for now – Okamisomething Dec 25 '18 at 8:38
  • If its done, please mark it as solved. And yeah uh can ping me here ..lol :-D – cloud.009 Dec 25 '18 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.