1

I just bought a Dell Precision 5530 with a Xeon(R) E-2176M, Quadro P2000, 16GB, 4K Touchscreen and 256gb SSD.

It came with Ubuntu 16.04 installed, but it wasn't really stable so I installed Ubuntu 18.10. No problems with installation but here are the problems I have using it :

  • Sometimes cursor and system freeze and I'm forced to shutdown the computer using the power button
  • Fans are running in a mysterious way, sometimes they just start and run @ 2500rpm and stop 10s later over and over again, while the CPU temp is about 45-50°C.
  • When the system goes to sleep after inactivity or after closing the laptop, it's impossible to wake it up, I'm forced to hard reboot.

What I've tried :

  • Updating bios to 1.6.0
  • Installing NVIDIA 415 driver (and using NVIDIA driver instead of xorg-video-nouveau)
  • Editing my /etc/default/grub file to :

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0" GRUB_CMDLINE_LINUX="acpi_osi=Linux-Dell-Video"

Do you have any idea what I could do ? Maybe I should try 18.04 but I'm not quiet sure if it's going to be any better.

Thanks

0

I don't have the exact same specs as your model. However I've got mine finally working with the following setup.

  • Ubuntu 18.04
  • No changes to grub
  • Installed all the linux-generic-hwe packages
  • installed the nvidia-390 driver

After this everything (suspend ect.) seems to be working in Gnome Wayland and ARMA 3 gives me decent frame rates. I've only tried it today and therefore haven't really invested much time into Gnome Xorg or i3wm. However it seems to crash everytime I select one of those environments.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.