First off, I am a new Linux user and I am still learning how everything works etc... I have been having problems running Linux on my Dell Inspiron 5575 with the Raven Ridge Ryzen 5 2400G. Random freeze up and black screens on boot. nomodeset makes the system rock solid with very poor graphics. I have updated the Kernel to 4.19 and I attempted to update mesa to 18.2.2, but i was unsuccessful at doing so... (I tried installing the PPA from the Ubuntu-x repository, but i believe it is written for Ubuntu 18) After running the commands, my mesa version is still 18.0... Sooo I downloaded Ubuntu 18 to see if i could get that to work, but i have been unable to get it to boot without freezing at a black screen. (One time it did boot all the way up, but i had a split screen that was unusable) I tried nomodeset to no avail. I really want to run an learn how to use Linux on my machine, I found that i really like this distro called Zorin. I hope maybe you guys can help me get this running. Thanks, Derek

  • All Dell seem to need Dell UEFI update an dif SSD firmware update. But Ryzen's seem to need even newer kernels than in default 18.04. Is there some real reason for 16.04? New hardware almost always requires the newest distribution to have newest kernel & drivers. While not Dell: Gigabyte B450 Ryzen needs kernel & mesa drivers ubuntuforums.org/showthread.php?t=2408247 Asus B350M-A needs newer kernel that 18.04 default ubuntuforums.org/showthread.php?t=2391892 & ubuntuforums.org/… – oldfred Dec 23 '18 at 4:53
  • 3
    Possible duplicate of What is needed to use Raven Ridge Ryzen 5 2400G?. According to that dupe, the hardware became usable in May 2018, so it missed 18.04, – user535733 Dec 23 '18 at 4:53
  • I believe that the problem lies in needing a mesa upgrade to 18.2... but im having issues getting it to install. Is it possible to get mesa 18.2 installed on 16.04? Or am i burnt? Zorin is supposed to release a new version based on 18.04 next month. I was hoping to get the old version to at least work until then... Even still, Im not sure how to get the 18.04 installer to even run without major graphics problems on boot... Thanks again for your time – Derek Stephens Dec 23 '18 at 7:33
  • Voting to close - this is a Zorin question. "Based on" does not mean "Official flavor of." Very sorry, but we provide support for (only) official flavors here. We do not keep track of the changes that other distros make to our codebase - that's why Zorin has it's own support. Note that 'based on 18.04' might still be too early for your hardware. Try LiveUSBs of Ubuntu 18.04 and 18.10 to easily answer your own question - they are free. – user535733 Dec 23 '18 at 13:42
  • Ok, i downloaded the 18.10 live USB- same problem black screen or black screen w/frozen curser. Any ideas? 18.04 does the same thing... I tried nomodeset, but it doesn't seem to have any effect... error [amdgpu] unable to locate bios ROM – Derek Stephens Dec 23 '18 at 17:15

Yep you were right, After playing around with the BIOS for a while- UEFI boot, Legacy boot disabled, secure boot disabled, legacy boot roms enabled. and setting nomodeset in the live USB grub, I got the installer to load for Ubuntu 18.10. To my surprise, it booted right up without issue after the install and i didn't even have to add the nomodeset command! :D Graphics look good. Thanks for your help!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.