1

I'm running a dual boot computer with Ubuntu 18.04 and Windows 10. The sound on my computer has been working normally up until yesterday. I closed the computer lid and left to do something else, when I came back and opened it the sound stopped working. I only get a dummy output label on the sound output device. If I log into Windows, it can't find any sound output there either. I tried connecting normal headphones to the computer, but still I get no sound. Bluetooth headphones do work. Since the problem seems to be on both operating systems, I think the problem is with the sound card.

I'm trying to find out if I need to install a new sound card, or if there is something I can do to fix this issue. I think that since the sound does not work on Windows either, it is the sound card that is the problem. But I want to ask someone that might have a better grasp of this than I do.

To begin with I have to be honest and say that I tried lots of stuff I found online before I started documenting it. I used to (only checked this after the problem started) get something of the order

cat /proc/asound/cards

-- No sound card detected---

The file has since been deleted by something I've done.

I tried doing the

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload

routine that I see in some solutions. Doing this used to run fine, but did not fix my problem. Now I get

sudo apt-get remove --purge alsa-base pulseaudio

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

I think this issue started after removing some old linux kernel headers using sudo apt autoremove. Running dpkg --configure -a starts the uninstall and install but it never finishes.

sudo dpkg --configure -a

Setting up oem-audio-hda-daily-dkms (0.201808050301~ubuntu18.04.1) ...
Removing old oem-audio-hda-daily-0.201808050301~ubuntu18.04.1 DKMS files...

-------- Uninstall Beginning --------
Module:  oem-audio-hda-daily
Version: 0.201808050301~ubuntu18.04.1
Kernel:  4.15.0-43-generic (x86_64)
-------------------------------------

Status: This module version was INACTIVE for this kernel.
depmod.......

DKMS: uninstall completed.

------------------------------
Deleting module version: 0.201808050301~ubuntu18.04.1 
completely from the DKMS tree.
------------------------------
Done.
Loading new oem-audio-hda-daily-0.201808050301~ubuntu18.04.1 DKMS files...
First Installation: checking all kernels...
Building only for 4.15.0-43-generic
Building for architecture x86_64
Building initial module for 4.15.0-43-generic

The terminal then hangs on this last line and nothing happens. Even after an hour nothing happens. The process can't be stopped or paused using CTRl+C or Z. I'm thinking that maybe it is trying to do something with the sound card and it doesn't work so it fails. Any ideas here?

Has anyone experienced a similar problem? Or does anyone know how I can fix this?



Here are some outputs from my terminal:

sudo aplay -l

aplay: device_list:270: no soundcards found...

pulseaudio

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

sudo alsa force-reload

Unloading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
Loading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

pacmd list-sinks

sink(s) available.
index: 0
name: <auto_null>
driver: <module-null-sink.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE 
priority: 1000
volume: front-left: 35388 /  54% / -16.06 dB,   front-right: 35388 /  54% / -16.06 dB
        balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 344 KiB
max rewind: 344 KiB
monitor source: 0
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
module: 11
properties:
    device.description = "Dummy Output"
    device.class = "abstract"
    device.icon_name = "audio-card"

lspci -v | grep -A7 -i "audio"

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
Subsystem: Hewlett-Packard Company Sunrise Point-H HD Audio
Flags: bus master, fast devsel, latency 32, IRQ 134
Memory at a4428000 (64-bit, non-prefetchable) [size=16K]
Memory at a4410000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
0

My problem seems to more or less have fixed itself. One day when I booted back into Windows I received a message from my computer to reboot, and I did. When I came back the sound was working normally. I'm guessing it installed a driver, although I had already checked for driver issues when the problem first began. When I booted back into Ubuntu, I had sound on only the left side. I still had the same problem with sudo dpkg --configure -a as before. I uninstalled oem-audio-hda-daily-dkms, reinstalled alsa-base and pulseaudio, and now it works normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.