8

Ubuntu 18.04 Cinnamon. The Fn + s screenshot tool is filling my ~/Pictures/ folder with unnecessary screenshots from accidental keystrokes. How do I disable this permanently?

The Menu > Keyboard dialog has a 'Shortcuts' tab, but neither 'screenshot' nor Fn + s appear in any of its options.

This question is an exact duplicate of someone else's question for 17.10 from a year ago that still has no comments or answers.

Edit No one even seems to know what the problem even is. So, the question at hand now is:

Is the source of this problem

  • The BIOS,
  • The OS (Ubuntu 18.04 Cinnamon), or
  • The keyboard?

Can anyone suggest a method for determining which is at fault, so that I can then focus on that?

It's a laptop, so I can't change out the keyboard.

  • Well, there just may not be people around here who've experienced and solved the same problem. This mentions cinnamon-settings → Keyboard → Keyboard Shortcuts → System → Screenshots and Recording. Maybe you can consider filing an issue at GitHub. But do make it clear that you're on Ubuntu (plus whatever the original desktop environment (DE) is). Sometimes, slapping one DE on top of another may have unintended consequences. – DK Bose Dec 23 '18 at 2:22
  • I'd like this question answered too. Meanwhile, try checking your BIOS settings. If this applies, this may help too: askubuntu.com/questions/985946/…. For me, however, I'd still like to disable Fn + S and be done. – Gabriel Staples Feb 2 at 7:08
  • Have you tried creating a shortcut for it and directing that keystroke to something else, like a blank script? My keyboards don't even have a Fn key, so I cant test.... And the one that does have a Fn key, the computer doesn't even react to it. Have you checked under gsettings? "gsettings list-recursively | grep screenshot" on my computer lists the shortcuts that can be manipulated. What is the output of that command? – WU-TANG Jul 13 at 16:02
2
+50

Note, some keyboard, BIOS combinations actually send "Print Screen" when Fn+s is pushed.

  1. Settings
  2. Devices
  3. Keyboard
  4. Scroll Down to "Save a screenshot to Pictures"
  5. If it shows "Print", click it.
  6. Hit your Backspace Key to disable the function, or assign to another key.
  7. Click "Set"
  8. Verify it now shows Disabled.
  9. Exit settings

View of settings screen:

enter image description here

| improve this answer | |
  • As illogical as this seems, this actually works. You would have thought that only disables the print button. So yes the Fn button is actually modifying the S to be the print button. You are losing your print button here, so you may want to map some other button to the screenshot function. And there are no answers anywhere about that, that I could find... so I am guessing no one even bothered ever trying it – WU-TANG Jul 13 at 22:58
  • Thanks for the suggestion! This solution disables the concept of "print screen" entirely. It prevents the accidental keystrokes problem, but by crippling the system's functionality, which is not what I consider an acceptable solution, so I'm leaving the question open. – Darien Marks Sep 12 at 21:00
  • You can get a different keyboard / bios / computer that does not send "Print Screen" when you press fn+s. or you can set the function to another key you like better. – 73Gavin Sep 26 at 17:39
0

(update *** This should only be the answer if you have already failed after trying 73Gavin's answer... Which most people have probably already investigated on their own and blew off without trying(even me). But it actually worked on my system.)

The answer: Get another keyboard

It seems I lied.. I found another laptop I have that has a Fn key. It is a Lenovo brand, running ubuntu MATE 18.04. On that laptop I can reproduce the behavior you are describing.

The little I have been able to determine from everything that I have tried and read, the Fn key does not produce anything for the OS to directly consume. So the Fn key's keypresses aren't detected. Which is why when I tried to make a shortcut with the Fn key (like I suggested) it doesn't detect anything happening. From what I understand, the Fn key modifies the output of the other key being pressed. And that behavior is determined by the keyboard itself.

...Which is why when I plug a separate USB keyboard into my Lenovo laptop, the Fn+s does not produce screeshots from that keyboard.

....Hopefully you're on a desktop

(but, seeing that I can't see how it is possible at all for anyone to hit that key combination by mistake frequently, I would have to assume that you actually use your Fn key regularly. I would warn that this solution may be taking away from some other functions that you are used to?)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.