This is confusing me a lot, I followed suggestions from a lot of answers here and for some reason it is still not working at all. Please bear with me as I explain what is happening.

I have a folder located at /home/admin/shared, I want to give a group called developers access (read and write) to this specific folder.

I have created the group and set it as the owner of the folder with this:

sudo chgrp -R developers /home/admin/shared

I then run ls -l /home/admin to check who owns the folder:

drwxrwxrwx  7 admin developers 4096 Dec 20 19:10  shared

I even check what groups my user is part of with

groups {username}

And it's right.

However both from SSH and FTP Client (Filezilla), every time I try to move to /home/admin/shared, I receive a permission denied error.

I've tried to use chmod too, but with the same results.

How do I fix this?


Kept trying without any luck.

I ended up creating a third folder /home/shared and then making the developers group owner of that and it started working fine.

I'd still like to know if there's a fix to my original question though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.