0

I'm using pantheon-terminal (from Elementary OS repo) on Ubuntu 18.10 because it will send desktop notification when a long running task completes which is a handy feature for me.

However, with recent update (don't know the source cause yet) but pantheon-terminal stop sending notification, or maybe GNOME shell doesn't show the notification for some reason. I'm using default bash shell, and AFAIK, pantheon-terminal support notifications on bash and fish shell without any extra config.

Does anybody using pantheon-terminal on Ubuntu and have any ideas how to fix this?

I have tried remove and reinstall pantheon-terminal but it still doesn't work. I tried searching issues in the project github, but it seem there's no related issues. And since I'm not on Pantheon DE, I don't know if it is the app or the DE to blame.

Current pantheon-terminal version: 5.3.3+r1284+pkg65~daily~ubuntu18.10.1

  • 1
    Ubuntu should be able to do this without resorting to pantheon: askubuntu.com/a/748923/248158 and askubuntu.com/q/749202/248158 – DK Bose Dec 21 '18 at 4:06
  • Thanks. I may consider undistract-me if there's no solution. But I'm hoping this can be fixed without resorting to additional tool. – Thanh Tran Dec 21 '18 at 5:24
  • Did you check the notify settings in the Settings? Also run ls; alert --urgency=critical from terminal to test notification. – abu_bua Dec 23 '18 at 0:05
  • 1
    I have checked notification settings and successfully run notify from terminal. All seem normal. I think this is caused from recent update of gnome-shell. Honestly, I'm so frustrated with gnome-shell that I have switched to pantheon-desktop and pantheon-terminal's notification works again. – Thanh Tran Dec 28 '18 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.