0

I have one disk of a 2 disk raid1 array that failed in the raid device. The manufacturer and subsequent investigation indicates it is formatted as a linux disk.

fdisk -l displays

Device       Start        End    Sectors   Size Type
/dev/sdb1       41       1953       1913 956.5K Microsoft basic data
/dev/sdb2 ...
...
/dev/sdb9  6504448    8503295    1998848   976M Microsoft basic data
/dev/sdb10 8503296 7814035254 7805531959   3.6T Microsoft basic data

I run

sudo mount /dev/sdb10 /media/seagate

and get

mount: /media/seagate: unknown filesystem type 'linux_raid_member'.

Following the advice here I ran

sudo mdadm --assemble --run /dev/md0 /dev/sdb10

producing:

mdadm: /dev/sdb10 is busy - skipping

mdadm --examine produces

         Magic : a92b4efc
        Version : 1.2
    Feature Map : 0x0
     Array UUID : e733e938:772dc035:5c104e46:4d4fe2da
           Name : BA-001075384F44:8
  Creation Time : Wed Apr 24 18:37:09 2013
     Raid Level : raid1
   Raid Devices : 2

 Avail Dev Size : 7805529911 (3721.97 GiB 3996.43 GB)
     Array Size : 3902764819 (3721.97 GiB 3996.43 GB)
  Used Dev Size : 7805529638 (3721.97 GiB 3996.43 GB)
    Data Offset : 2048 sectors
   Super Offset : 8 sectors
   Unused Space : before=1968 sectors, after=273 sectors
          State : clean
    Device UUID : b8ca69f9:bba3bbc2:33f7033e:67308d4f

    Update Time : Fri Dec 14 13:54:41 2018
       Checksum : a891168f - correct
         Events : 2


   Device Role : Active device 0
   Array State : AA ('A' == active, '.' == missing, 'R' == replacing)

I am at an impasse it seems. Can anyone point me in the right direction for mounting this partition and (hopefully) recovering the data on it?

Thanks in advance.

0

I used these instructions and was able to see the LVM both in terminal window and in GUI interface.

But then:

mount /dev/vg8/lv8 /mnt/sd1 

Generated: “Wrong fs type, bad option, bad superblock on /dev/mapper/vg8-lv8, missing codepage or helper program, or other error”

Followed the advice and used

mkfs.ext4 /dev/vg8/lv8  

But got message

/dev/vg8/lv8 contains a ext4 file system
  last mounted on /shares/public on Tue Sept 16 20:00:52 1975
Proceed anyway? 

JerryFrey suggested using a file recovery such as foremost. I ended up doing that and recovered all the files albeit without file names or a directory tree.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.