85

If I open a link sent to me on Slack, the new browser window opened shows up as 'another' Slack window. Is there any way to have it correctly group the new browser window with the existing browser windows? I'm on Ubuntu 18.04 running gnome.

3
  • 3
    I have the same problem too, but it only happens when my default browser is not already opened. If my default browser is already launched, the link from slack will be opened using the browser without 'another' Slack window is opened.
    – singrium
    Nov 20, 2019 at 9:41
  • @singrium this is true for me with Chrome as default browser, with Firefox the issue persists even if Firefox is already opened. Oct 16, 2020 at 15:22
  • On Ubuntu 21.04 we're facing a new issue. If Firefox isn't already running, clicking a link in Slack will cause the Firefox crash reporter to open. Jul 23, 2021 at 17:23

3 Answers 3

138

Firefox users have this workaround:

  1. In Slack, click on a web link
  2. In the new Firefox browser instance opened by Slack, go to "about:profiles"
  3. Change the profile used as default to your regular profile

Thanks to Michev for the comment on the snapd bugtracker: https://bugs.launchpad.net/snapd/+bug/1835024/comments/13

13
  • 24
    THIS is the best solution. It fixes the issue with all Snap apps at once, and doesn't ask you to manually install a single version (which won't then be updated) from the command line.
    – Lambart
    Feb 14, 2020 at 1:49
  • 8
    Cleanest solutions, work like a charme! Mar 13, 2020 at 8:31
  • 3
    I cannot make any changes there, since the profile shown inside my Slack's instance of Firefox is named "default", but the same is the name of the profile of my normal Firefox instance outside of Slack. May 4, 2020 at 8:05
  • 3
    Because that's a firefox url. I'm also looking for a chrome fix. .
    – Kaigo
    May 7, 2020 at 16:55
  • 2
    Works, but on Ubuntu 20.04, I still need to open Firefox first, otherwise the in-app browser is used again. Oct 22, 2020 at 5:38
40

I had the same problem, I uninstalled the app via Ubuntu Software, then downloaded the latest .deb package in https://slack.com/downloads/linux

And installed the package with sudo dpkg -i slack-desktop-*.deb

And it worked all fine

The problem seems to be with the snap packaging of slack, not the app itself.

8
  • 1
    Thanks Nicolas, this answer saved me a lot of frustration!
    – pjcdawkins
    Aug 2, 2019 at 14:28
  • 4
    It looks like a big disadvantage of snap packages compared to classic packages. Sep 20, 2019 at 10:11
  • 2
    Damn... So hard to find this! Thanks a lot
    – fiskolin
    Nov 14, 2019 at 14:55
  • 4
    Unless you have other reasons for avoiding Snap apps, the best solution is bitcrew's: askubuntu.com/a/1209485/54675 ...as it fixes the problem without asking you to install a single version of Slack (etc.), which will then never be automatically updated. It will fix this issue in all your Snap apps.
    – Lambart
    Feb 14, 2020 at 1:52
  • 2
    I originally did the about:profiles fix in the top rated answer, but after 6 months, the problem came back. This time, the fix in this answer is what worked.
    – Nadine
    Nov 17, 2020 at 8:23
3

After removing Slack via the Software Center, open your terminal and run:

$ wget https://downloads.slack-edge.com/linux_releases/slack-desktop-4.0.2-amd64.deb
$ sudo apt --fix-broken install ./slack-desktop-*.deb
$ sudo apt install ./slack-desktop-*.deb
1
  • 4
    This references a specific version which is now out of date
    – Tom
    Jan 14, 2020 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.