0

When I try to install oyente i'm getting this error. It is a Ethereum tool.

Command used:

pip2 install oyente

Error:

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-YK4pz0/eth-account/

Total Output of the error:

Collecting oyente

Using cached https://files.pythonhosted.org/packages/13/3c/52b8dee604cbdf35c1d65a141b779d9c14c8d313251c697b40a93f58d3d5/oyente-0.2.7-py2-none-any.whl

Collecting z3-solver (from oyente)

Using cached https://files.pythonhosted.org/packages/df/3a/c31287d0520bd288cccd336618fae9271b3c4ac22efb360eaa0c533f5db5/z3_solver-4.8.0.0.post1-py2.py3-none-manylinux1_x86_64.whl

Collecting web3 (from oyente)

Using cached https://files.pythonhosted.org/packages/85/01/eacb73ae16364295bf26cba4aacc94e513f5feae54dbb5f8121bec697e49/web3-4.8.1.tar.gz
Ignoring toolz: markers 'implementation_name == "pypy"' don't match your environment
Ignoring cytoolz: markers 'implementation_name == "cpython"' don't match your environment
Ignoring pypiwin32: markers 'platform_system == "Windows"' don't match your environment

Collecting requests (from oyente)

Using cached https://files.pythonhosted.org/packages/7d/e3/20f3d364d6c8e5d2353c72a67778eb189176f08e873c9900e10c0287b84b/requests-2.21.0-py2.py3-none-any.whl

Collecting eth-abi<2.0.0,>=1.2.0 (from web3->oyente)

Using cached https://files.pythonhosted.org/packages/a0/54/cafbdd18686185617fb0208f9435708abc1f6ab60c414b2c4328e9c73ea7/eth-abi-1.3.0.tar.gz

Collecting eth-account<0.4.0,>=0.2.1 (from web3->oyente)

Using cached https://files.pythonhosted.org/packages/23/71/5b510d44c18e3ea3247bf7979f2f6734e250574f3224aab6c4704a0b4797/eth-account-0.3.0.tar.gz

Complete output from command python setup.py egg_info:

Installed /tmp/pip-install-YK4pz0/eth-account/.eggs/setuptools_markdown-0.2-py2.7.egg
Searching for pypandoc
Reading https://pypi.python.org/simple/pypandoc/
Best match: pypandoc 1.4
Downloading https://files.pythonhosted.org/packages/71/81/00184643e5a10a456b4118fc12c96780823adb8ed974eb2289f29703b29b/pypandoc-1.4.tar.gz#sha256=e914e6d5f84a76764887e4d909b09d63308725f0cbb5293872c2c92f07c11a5b
Processing pypandoc-1.4.tar.gz
Writing /tmp/easy_install-8SnDgF/pypandoc-1.4/setup.cfg
Running pypandoc-1.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-8SnDgF/pypandoc-1.4/egg-dist-tmp-8Swedy
zip_safe flag not set; analyzing archive contents...
pypandoc.__init__: module references __file__
creating /tmp/pip-install-YK4pz0/eth-account/.eggs/pypandoc-1.4-py2.7.egg
Extracting pypandoc-1.4-py2.7.egg to /tmp/pip-install-YK4pz0/eth-account/.eggs

Installed /tmp/pip-install-YK4pz0/eth-account/.eggs/pypandoc-1.4-py2.7.egg
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
  warnings.warn(msg)
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/tmp/pip-install-YK4pz0/eth-account/setup.py", line 71, in <module>
    'Programming Language :: Python :: Implementation :: PyPy',
  File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 272, in __init__
    _Distribution.__init__(self,attrs)
  File "/usr/lib/python2.7/distutils/dist.py", line 287, in __init__
    self.finalize_options()
  File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 327, in finalize_options
    ep.load()(self, ep.name, value)
  File "/tmp/pip-install-YK4pz0/eth-account/.eggs/setuptools_markdown-0.2-py2.7.egg/setuptools_markdown.py", line 22, in long_description_markdown_filename
    output = pypandoc.convert(markdown_filename, 'rst')
  File "/tmp/pip-install-YK4pz0/eth-account/.eggs/pypandoc-1.4-py2.7.egg/pypandoc/__init__.py", line 66, in convert
    raise RuntimeError("Format missing, but need one (identified source as text as no "
RuntimeError: Format missing, but need one (identified source as text as no file with that name was found).

----------

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-YK4pz0/eth-account/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.