1

This question already has an answer here:

I have found that terminal on my PC doesn't work properly. I have tried to install a program and it doesn't work. I have tried to install some programs over Ubuntu software center but that also turned out not to be working.

I used command

sudo apt install (name of the program)

In this case Code::Blocks

After that terminal gives me an error message :

codeblocks : depends: libcodeblocks0 it isn't going to be installed 
depends: codeblocks-common (= 13.12+dfsg-4) it isn't going to be installed 
kde-telephaty-minimal: Depends: kde-confing-telephaty-accounts (=> 15.04.0) but it isn't going to be installed 

I searched for the solution online but it didn't help, I guess it has to do with that Kde-telephaty thing but I don't really understand what that is...
I want this thing to be gone because it prevents me from installing stuff new programs. How can I fix this and what causes it?

Results of sudo apt-get -f install:

sudo apt-get -f install 
Reading the file list... Done
I make a tree of interdependence      
Reading the status information... Done
correcting interdependence... Done
The following packages are installed individually and are no longer needed:
  cabextract clamtk exo-utils fonts-horai-umefont fonts-unfonts-core
  gcc-5-base:i386 gir1.2-nautilus-3.0 gnome-exe-thumbnailer gnome-icon-theme
  hddtemp kde-l10n-engb kde-l10n-ru kde-l10n-sr libasn1-8-heimdal:i386
  libasound2:i386 libasound2-plugins:i386 libasyncns0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libbsd0:i386 libcapi20-3 libcapi20-3:i386 libcommon-sense-perl libcups2:i386
  libdbus-1-3:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexif12:i386
  libexo-1-0 libexo-common libexo-helpers libexpat1:i386 libffi6:i386
  libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgarcon-1-0
  libgarcon-common libgd3:i386 libgif7:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesAa:i386 libglu1-mesa:i386 libgmp10:i386
  libgnutls30:i386 libgphoto2-6:i386 libgphoto2-port12:i386
  libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386
  libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhogweed4:i386
  libhx509-5-heimdal:i386 libice6:i386 libicu55:i386 libidn11:i386
  libieee1284-3:i386 libjack-jackd2-1:i386 libjavascriptcoregtk-3.0-0
  libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libjson-c2:i386 libjson-perl
  libjson-xs-perl libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libllvm4.0 libllvm5.0
  libllvm5.0:i386 libllvm6.0:i386 libltdl7:i386 libmpg123-0:i386 libmsi0
  libnettle6:i386 libogg0:i386 libopenal1:i386 libosmesa6 libosmesa6:i386
  libp11-kit-gnome-keyring:i386 libp11-kit0:i386 libpciaccess0:i386
  libpng12-0:i386 libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386
  libsane:i386 libsensors4:i386 libsm6:i386 libsndfile1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-6:i386
  libtext-csv-perl libtext-csv-xs-perl libtiff5:i386 libtxc-dxtn-s2tc0:i386
  libtypes-serialiser-perl libunibreak1 libusb-1.0-0:i386 libv4l-0:i386
  libv4lconvert0:i386 libvorbis0a:i386 libvorbisenc2:i386 libvpx3:i386
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwind0-heimdal:i386
  libwnck-common libwnck22 libwrap0:i386 libx11-6:i386 libx11-xcb1:i386
  libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfce4ui-1-0 libxfce4ui-common libxfce4util-bin libxfce4util-common
  libxfce4util7 libxfconf-0-2 libxfixes3:i386 libxi6:i386 libxinerama1:i386
  libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
  libxshmfence1:i386 libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386
  libzlcore-data libzlcore0.13 libzltext-data libzltext0.13 libzlui-qt4
  linux-headers-4.15.0-36 linux-headers-4.15.0-36-generic
  linux-image-4.15.0-36-generic linux-modules-4.15.0-36-generic
  linux-modules-extra-4.15.0-36-generic msitools ocl-icd-libopencl1:i386 p7zip
  psensor-common python-nautilus ttf-wqy-microhei wine-gecko2.21
  wine-gecko2.21:i386 wine-mono0.0.8 xfce4-panel xfconf
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
kde-config-telepathy-accounts
The following new packages will be installed:
  kde-config-telepathy-accounts
upgraded — 0, newly-installed — 1, for deleting— 0, and non upgraded — 0.
incomplete installed or removed— 2.
i need to download 0 B/137 kB archive.
After this action, on the disk will be used 825 kB additional space.
Do you want to continue? [Y/n] y
(reading the database ... 376714 files or directories is currently available.)
Peparing for unziping „.../kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb“ ...
Unziping „kde-config-telepathy-accounts“ (4:15.12.3-0ubuntu1) ...
dpkg: error processing archive „/var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb“ (--unpack):
 trying to overwrite „/usr/share/accounts/services/google-im.service“, which is also included in the package account-plugin-google 0.12+16.04.20160126-0ubuntu1
I'm processing triggers for„libc-bin“ (2.23-0ubuntu10) ...
Errors were found during processing:
 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

marked as duplicate by N0rbert, karel, Eric Carvalho, pLumo, Kulfy Dec 20 '18 at 15:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What makes you sure, that the error is "trying to overwrite file"? It could be also askubuntu.com/questions/140246/…. I think some information is missing here. OP, please edit the question and add the full output of sudo apt install -f. – pLumo Dec 20 '18 at 7:41
  • Added the full output – Vls3 Dec 27 '18 at 7:47
  • @Kulfy Sorry, I am new to this stuff... – Vls3 Dec 27 '18 at 8:54
0

You can remove all of the files creating the problem.

Steps

dpkg --list | grep codeblock

this will list all the codeblock relative packages

sudo dpkg --purge codeblocks-dev

remove the packages that have unmet dependencies

sudo apt-get update && sudo apt-get upgrade

alawys be up-to-date... It might create problems when you don't upgrade.

sudo apt-get -f install

this will resume the incomplete install.

sudo apt-get clean

at last.

  • Thanks cloud.009 but that didn't resolve my problem. I got this error message /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – Vls3 Dec 20 '18 at 22:35
  • go to /usr/bin/dpkg and remove the file codeblock file...it helped me once when i got stuck in the same place.. – cloud.009 Dec 21 '18 at 11:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.