1

This is not a 'How to Configure Scroll/Buttons' type question.

I have a Logitech Marble Mouse (a two-button trackball), model number T-CM14.

Problem: The mouse pointer on screen is very laggy, to the point of not being usable: approximately ten full rotations of the trackball to get the pointer from the top of the screen to the bottom, for example.

System specification:

  • OS: Ubuntu Studio 18.04 (Xfce) x64
  • Newly installed, Partner Repositories enabled and Restricted-Extras added
  • PC: Dell Insperon with USB-only connections

The trackball is attached using a USB-to-PS/2 adapter:

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 004: ID 04d9:1400 Holtek Semiconductor, Inc. PS/2 keyboard + mouse controller
Bus 002 Device 006: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 002: ID 413c:2107 Dell Computer Corp. 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

(I should point out that the 'M105 Optical Mouse' is a second pointing device I have plugged in to get a working pointer on-screen, having it plugged in, or not, doesn't seem to affect the problem with the trackball's lack of performance.)

Funny thing was one time I had rebooted with just the trackball/adapter installed, this time in the front USB port, and it started working like normal. But this condition did not last and I am back to adding the standard mouse to get that pointer where it needs to be, on-screen.

How to fix my mouse pointer to respond to the trackball's rotation like it's supposed to?

0

The effect you are describing may be dependent on the resolution of the screen. I have found that for a high resolution screen, I need to scroll more as well.

Two settings:

  • Acceleration to max. This can be set in gnome config, or via xinput set-prop "Logitech USB Trackball" 328 1.0 or via the equivalent in xorg conf, in general, I use the following /etc/X11/xorg.conf.d/10-libinput.conf
Section "InputClass"
     Identifier "Marble Mouse"
     MatchProduct "Logitech USB Trackball"
     Driver "libinput"
     Option "ScrollMethod" "button"
     Option "ScrollButton" "8"
     Option "AccelSpeed" "1"
     # Option "TransformationMatrix" "2.4 0 0 0 2.4 0 0 0 1"
EndSection

as I also want scrolling with wheel by clicking on the left small button. The commented TransformationMatrix allows to skip pixels and move faster, but I prefer to change the DPI as below instead.

  • Set a custom DPI through /etc/udev/hwdb.d/71-mouse-local.hwdb
# Logitech Marble Mouse
#id obtained by: mouse-dpi-tool  /dev/input/event4
mouse:usb:v046dpc408:name:Logitech USB Trackball:
# keep space below
 MOUSE_DPI=100@125

and then udevadm hwdb --update, udevadm control --reload-rules && udevadm trigger and unplug, plug mouse. The DPI of 100 may be too sensitive for some, you could replace by 200@125.

In your case, the id is likely v04d9p1400, you probably need to check with mouse-dpi-tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.