0

Folks, I am having the suspend/wakeup problem with my Dell XPS-15-9570, removed windows 10 and installed ubuntu 18.04.01 LTS.

Installed nvidia driver 410 for my nvidia card (GeForce GTX 1050 Ti Mobile) as suggested by nvidia. Reboot happens fine, but when I suspend the machine, and try to wake it up, I get a blank screen with the cursor on the top left corner, and nothing happens after that.

Tried setting : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" GRUB_CMDLINE_LINUX="noveau.blacklist=1 nouveau.modeset=0"

nothing seems to work. Any help highly appreciated !!!!

nvidia-smi shows :

Tue Dec 18 14:05:26 2018 +-----------------------------------------------------------------------------+ | NVIDIA-SMI 410.78 Driver Version: 410.78 CUDA Version: 10.0 | |-------------------------------+----------------------+----------------------+ | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GeForce GTX 105... Off | 00000000:01:00.0 Off | N/A | | N/A 40C P0 N/A / N/A | 290MiB / 4042MiB | 2% Default | +-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | 0 1340 G /usr/lib/xorg/Xorg 121MiB | | 0 1516 G /usr/bin/gnome-shell 76MiB | | 0 1955 G ...uest-channel-token=15470493938553774371 93MiB | +-----------------------------------------------------------------------------+

0

I have the same machine, and encountered the same issue running Ubuntu 18.10.

The best work around I've found is to disable the NVIDIA card for normal use and enable it for gaming, etc. This also improves the battery life during normal use.

The NVIDIA card can be enabled/disabled by launching NVIDIA X Server Settings, and selecting between the NVIDIA and Intel cards under PRIME Profiles. In order for the change to take affect, you need to log out and back in.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.