17

Since recently, whenever a text-field (e.g. the address bar or the askubuntu search field) is highlighted inside Google Chrome, I cannot use Ubuntu shortcuts (e.g. Ctrl+W to close a window). When hitting Ctrl+W nothing happens. As soon as I press tab to leave the text-field, the shortcuts work as expected (e.g. Ctrl+W closes the window).

I have no idea why this happens. Any ideas how to debug or solve this?

I am using Ubuntu 18.04.1 LTS and Google Chrome 71.0.3578.98.

Edit: It seems that this issue is somehow connect to Keyboard Layouts. Mostly, I use the layout "English (US, intl., with dead Keys)". In this case, the above problem occurs and shortcuts no longer work when text fields are highlighted. When switching to "English (US)", Ctrl + w closes the window as intended, even when a text field is highlighted. (Credit to mr. Pavlikov)

  • 3
    I am seeing the same. Also on Chromium. NOT on Firefox or other applications. Also maybe worth noting that this is with Unity. – nkoren Dec 19 '18 at 17:23
  • 2
    Also worth noting that this happens with any selected input element, and also if the URL bar is selected. Basically any time any keyboard input is expected to be received, OS shortcut key combinations are blocked. – nkoren Dec 20 '18 at 12:14
  • Looks like a problem with ibus :/ Killing ibus-daemon works around the issue... not sure if it's a bug in ibus or in chromium. – Léo Lam Dec 25 '18 at 12:48
  • 1
    I have same issue on Ubuntu 18.10 / Google Chrome Version 71.0.3578.98 (Official Build) (64-bit). It only happens when I have alternate keyboard layout (RUS in my case), and is fine with EN layout. – mr. Pavlikov Dec 26 '18 at 14:30
  • 1
    I upgraded to the chrome-unstable channel (version 73.0.3664.3) and that fixed the keyboard shortcut issues for me. – psanford Jan 16 at 17:51
7

Had the same problem. What worked for me was that I changed the order of language input on my system. Make sure your default language (the one you use the most) is the first on the 'Region & Languages' input sources tab. That would make your shortcuts work when using the first language, but not the second.

Hope this helps.

  • 1
    This makes me unreasonably angry. – unflores Jan 31 at 20:31
2

I also have same problem in ubuntu-mate 18.10 and google chrome 71

the problem is probably because there is no required library/package for the ibus to work in google chrome

installing these package fix the problem in my computer

sudo apt install ibus ibus-gtk ibus-gtk3 ibus-qt4

  • Thanks, but for me this didn't solve the problem. – physicsGuy Jan 3 at 19:12
  • 1
    This solved the problem for me, thanks! I knew it had to do with ibus as killing ibus-daemon works around the issue, but I'm not sure why this was needed. Installing ibus-qt4 probably isn't needed, though, considering Chromium doesn't use Qt4. – Léo Lam Jan 8 at 18:04
2

The update to Chrome 72 today solved the issue.

Related bug on the chromium bug tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=899881

Related fixing commit: https://chromium.googlesource.com/chromium/src.git/+/faa579def265753007f87c3ea85a907f0ed469b0

0

I am on Chrome Version 71.0.3578.98 (Official Build) (64-bit) and Ubuntu 18.10, I was having the same issues, including Alt+D was no longer working (focus address bar), and Ctrl+T (new tab).

I had some other non-related issues with my Thunderbolt laptop dock, and therefore I updated my Linux kernel to 4.20.0-042000rc7-lowlatency. This also solved my issues with not being able to hit all keycombinations in Chrome. Before the upgrade I was on 4.18.0-13 and 4.18.0-12.

  • The kernel doesn't have anything to do with keyboard shortcuts in this case. That's pretty much an userspace problem, and here it is in fact caused by ibus. That your problem got solved after you updated your kernel is very likely to be a coincidence. – Léo Lam Jan 8 at 18:03
0

I am on Chrome 71.0.3578.80 & Ubuntu 18.04. Same problem.

It's due to IBus input system - whenever it's selected in the Language Support, chrome shortcuts stop working in textbox (address bar, form, etc), but not elsewhere.

None of other input systems have the same problem: fcitx, gcin, etc.

PS: I verified on my Ubuntu that it has nothing to do with language, locale or keyboard layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.