0

I cannot ping a virtual image running as a qemu guest in Ubuntu 18.04.

The default yaml file in /etc/netplan/ is:

network:
  version: 2
  renderer: networkd
  ethernets:
    eno1:
      dhcp4: yes
      dhcp6: no

I have added another yaml file for the bridge interface as in this guide:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s25:
      dhcp4: true
  bridges:
    br0:
      addresses: [ 192.168.56.1/24 ]
      interfaces: [ vlan15 ]
  vlans:
    vlan15:
      accept-ra: no
      id: 15
      link: enp0s25

The bridge is created but I cannot ping. Here is the output on the console:

PING 192.168.56.7 (192.168.56.7) 56(84) bytes of data.
From 192.168.56.1 icmp_seq=1 Destination Host Unreachable
From 192.168.56.1 icmp_seq=2 Destination Host Unreachable
From 192.168.56.1 icmp_seq=3 Destination Host Unreachable

--- 192.168.56.7 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2040ms
pipe 3
0

I got the following configuration working (only one .yaml file is used):

network:
 version: 2
 renderer: networkd
 ethernets:
  eno1:
   dhcp4: yes
   dhcp6: no
  eno2: {}
 bridges:
  br0:
   addresses: [ 192.168.56.7/24 ]
   interfaces: [ vlan15]
 vlans:
  vlan15:
   accept-ra: no
   id: 15
   link: eno2

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.