0

I am trying to set up the Nvidia Driver on Ubuntu 18.04 LTS for my Lenovo Y510P Laptop. My laptop has a Nvidia Optimus Technology graphics card (GeForece GT 750M). I have tried using all of the additional Nvidia Drivers including current to old, 415, 410, 396, 390, and 340 (with ppa:graphics-drivers). I have tried using Bumblebee (which is no longer available using ppa:bumblebee/stable), I have tried changing .conf files, I have tried using bbswitch, Prime and others, but no luck. I either get a black screen with a blinking cursor in the top left corner, or a Login loop.

I have spent 5 days searching this and other forums trying to find a solution, but after trying dozens of different solution attempts, nothing works. Unfortunately, all forum topics I have found up to this point are very outdated and provide old solutions to additional software such as Bumblebee that is no longer available or updated. Please help.

0

As far as I remember you just have to follow the instructions here https://wiki.ubuntu.com/Bumblebee. For the sake of completeness I am just copying the relevant part in the next lines:

  1. Enable the Universe and Multiverse repositories in order to allow the bumblebee and nvidia packages to be installed
  2. Do sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic at your terminal
  3. Reboot.

Then read the "usage" subsection in the same link.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.