1

I have some experience with Ubuntu and the command line but I'm totally new to compiling. when I run ./configure I get a package requirement not met error that says gtk+ not found.

I have verified that two versions of gtk+ are installed(2+3),build-essentials are there, PKG_CONFIG_PATH is set(used apt-file search to find the path), everything that could be has been upgraded.

I've been at this for two days and have tried everything I found on the internet. I could really use some help. I apologize if this is a redundant question. Thanks in advance.

  • 1
    Is the development package for GTK+ installed (libgtk2.0-dev)? – steeldriver Dec 17 '18 at 0:31
  • Yes I neglected to mention that. Thanks for your interest! I searched up and down the internet and found a lot of useful suggestions and a lot of Ubuntu documentation. I tried everything I found. Incidentally I'm running 1804 bionic beaver. – Harry Busk Dec 17 '18 at 2:22
  • So, what does pkg-config --modversion gtk+-2.0 report? what version of Ubuntu are you using? If you pastebin the config.log file perhaps someone will be able to spot what's wrong. – steeldriver Dec 17 '18 at 2:30
  • hi! thanks to a fellow user I was able to make considerable progress. make install returned error 2. im going to dig into it a bit. – Harry Busk Dec 17 '18 at 3:49
0

Try the following to get all the dev libraries you need;

sudo apt-get install libgtkdataboxmm-dev fftw3-dev

Then do your ./configure && make

|improve this answer|||||
  • hey that was great! configure went without a hitch. so did make I think. make install returned a definite error2. i want to dig into this before i ask for more help. thank you. – Harry Busk Dec 17 '18 at 3:45
0

As xoscope is packaged in all supported Ubuntu versions, you should rely on the power APT.

Install package's build dependencies with

sudo apt-get build-dep xoscope

and continue as you tried.

|improve this answer|||||
0

As mentioned on @NOrbert answer section, xoscope package available in all supported Ubuntu versions. just follow the command :

sudo apt-get install xoscope libgtk2.0-dev

If you install xoscope package from build source-code like this github, you should install the dependencies :

sudo apt-get install libsx svgalib g3vga

and try compiling your source-code again!!

./configure;

Make sure when configuring the source-code, you have a log like :

...
Checking: <depend-packages> is YES
...

Instead

...
Checking: <depend-packages> is NO
...

If all the dependencies is right, you can install the .makefile files :

make; make install;

Hope this helps;

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.