12

A strange problem manifested on my machine recently, and I'm really at a loss when trying to resolve it, as I don't even know how to google this.


I was watching Netflix full-screen one fine day, on Firefox v64.0, on my Ubuntu 18.04.1 laptop. At some point, I thought I saw ghost images overlaid on my video. I thought my eyes were just tired and paid no attention to it, I closed the laptop and went to get some coffee.

Later on, while watching a YouTube video (again, fullscreen) and I thought I saw the ghost image again. I turned up my screen's brightness all the way to 100% and lo-and-behold, I could see my wallpaper through the full-screen video!

This has been going on for some days now, and I wasn't able to find what's causing it. Full screen videos on Netflix and YouTube have some sort of 10-20% transparency, and I can see my wallpaper behind them. This only happens when the video is playing. When I pause the video, transparency goes away. You can understand how this played with my mind a little bit at first.

Local video files on my machine, played through mpv, have no transparency issues.

To give you an example, I'm sorry but I literally took a photo of my laptop's monitor.

Here's a full screen YouTube video of a pure black screen, for 10 hours (It's just a video of all-black playback):

pic1

The image in the back (the ghost image I was seeing) is of course, nothing else other than my wallpaper:

enter image description here

The transparency is also captured in regular screenshots. Here's one of the above 100%-black-video fullscreened and playing. It isn't as visible because it's a software screenshot, but you can see the ghost image there too if you squint.

enter image description here

  • 2
    I really hope I'm not really losing my mind... – Dimitris Sfounis Dec 16 '18 at 22:25
14

My config is Firefox 64.0, Ubuntu 18.04.1. Experienced the same problem. After searching and reading, finally was able to fix it.

Changed layers.acceleration.force-enabled option to true in the about:config

Edit: You may also try to create mozilla.widget.use-argb-visuals as Boolean and set it to false in about:config

Source: Firefox Bug 1516224 Semi-Transparent YouTube video playback

  • Thank you, this worked. May I ask how you searched for it? What did you look for? Source on what was causing this? – Dimitris Sfounis Dec 20 '18 at 12:40
  • Searched for something like "ubuntu firefox fullscreen video transparent" and found this askubuntu.com/questions/1100753/… – Evgeny Dec 21 '18 at 2:20
  • This did fix the issue but caused other rendering issues for me – Erik van Velzen Jan 22 '19 at 17:15
0

In about:config setting gfx.xrender.enabled to true fixed it for me, with no rendering issues and no loss of performance.

0

Unfortunately, if your screen is o-led, this can be a cause of screen burn. It is a phenomenon that happens when your screen is exposed to the same images and the light effects the pixels permanently.

If the screen is LCD, then you should be fine.

To test this, pull up a white image as your wallpaper and see if you can see your old wallpaper on the white new one.

If there's screen burn-in, I'm sorry for your situation. It sucks.

https://www.cnet.com/news/oled-screen-burn-in-what-you-need-to-know/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.