1

I tried to upgrade from 18.04 to 18.10 but the upgrade failed half way because of unmet dependencies. It's specifically: python3-apt, apt-xapian-index, python3-newt:amd64, systemd, python3-gdbm:amd64, python-apt libpam-systemd:amd64, libudev1 that fails.

The python things seems to fail because libapt packages aren't up to date and udev fails bedcause ubuntu isn't up to date (so I'm guessing the system is still on 18.04)

The real problem however is Systemd. It fails because of libgpg. This is the error I get when doing trying to reconfigure via dpkg:

Setting up systemd (237-3ubuntu10.9) ...
systemctl: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
systemctl: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
systemd-machine-id-setup: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference

Here is the output from dpkg --configure --pending

+ dpkg --configure --pending
dpkg: dependency problems prevent configuration of python3-apt:
 python3-apt depends on libapt-inst2.0 (>= 1.6.5~); however:
  Version of libapt-inst2.0:amd64 on system is 1.2.29.
 python3-apt depends on libapt-pkg5.0 (>= 1.6.5~); however:
  Version of libapt-pkg5.0:amd64 on system is 1.2.29.

dpkg: error processing package python3-apt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apt-xapian-index:
 apt-xapian-index depends on python3-apt (>= 0.7.93.2); however:
  Package python3-apt is not configured yet.

dpkg: error processing package apt-xapian-index (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-newt:amd64:
 python3-newt:amd64 depends on libnewt0.52 (= 0.52.20-1ubuntu1); however:
  Version of libnewt0.52:amd64 on system is 0.52.18-1ubuntu2.

dpkg: error processing package python3-newt:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up systemd (237-3ubuntu10.9) ...
systemctl: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
systemctl: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
systemd-machine-id-setup: relocation error: /lib/x86_64-linux-gnu/libgcrypt.so.20: symbol gpgrt_get_syscall_clamp version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference
dpkg: error processing package systemd (--configure):
 installed systemd package post-installation script subprocess returned error exit status 127
dpkg: dependency problems prevent configuration of python3-gdbm:amd64:
 python3-gdbm:amd64 depends on libgdbm5 (>= 1.14); however:
  Package libgdbm5 is not installed.

dpkg: error processing package python3-gdbm:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-apt:
 python-apt depends on libapt-inst2.0 (>= 1.6.5~); however:
  Version of libapt-inst2.0:amd64 on system is 1.2.29.
 python-apt depends on libapt-pkg5.0 (>= 1.6.5~); however:
  Version of libapt-pkg5.0:amd64 on system is 1.2.29.

dpkg: error processing package python-apt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpam-systemd:amd64:
 libpam-systemd:amd64 depends on systemd (= 237-3ubuntu10.9); however:
  Package systemd is not configured yet.

dpkg: error processing package libpam-systemd:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python3-apt
 apt-xapian-index
 python3-newt:amd64
 systemd
 python3-gdbm:amd64
 python-apt
 libpam-systemd:amd64
  • 1
    A failed upgrade of this sort typically occurs when the user has failed to retunr their system to stock 18.04 condition by removing PPAs and other non-Ubuntu software that could break the upgrade. You have two choices: Trace the non-Ubuntu dependencies that broke the upgrade and remove them, or backup-and-reinstall – user535733 Dec 16 '18 at 22:38
  • @user535733 no files in /etc/apt/sources.list.d other than tor by torproject.org and nothing unusual in /etc/apt/sources.list. I don't think I've installed any PPAs. I do have some downloaded software there but it's mostly just PHP stuff without any dependencies. How would I trace the fault if apt doesn't work and I can't use systemctl? – Carlgo11 Dec 16 '18 at 23:28
  • 1
    Just about everything you need is in your own dpkg output, and your own investigation so far. You already know what the key blockers seem to be - try to upgrade each using dpkg, and pay close attention to the error messages in the output. It's a rabbit-hole, and it may go mighty deep. It's a project, not a small job. – user535733 Dec 17 '18 at 0:32
  • Please add output of ldd /lib/x86_64-linux-gnu/libgcrypt.so.20 to the question. – N0rbert Dec 17 '18 at 8:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.