0

I use JACK/qjackctl with the Calf Audio Plugins for a system-wide EQ. This means that I have to start and run these two programs in every session from beginning to end.

Adding them to the Startup Applications in Tweaks works. However, since these programs function like "set-and-forget" services, I would like to start them either minimized or on a different workspace.

In Compiz, the "Place Windows" plugin was able to put a specified window on another workspace in the background without switching to it, however this does not work anymore in 18.04.

There is a Gnome extension called "Auto Move Windows", which automatically puts application windows on a specific workspace, but adding these two programs does not work in the intended way, either because they start too early or because the destination workspace becomes the one the system starts up on, I am not sure.

Is there any way to start these two programs "out of the way", either with Startup Applications, some other setting or something like a startup script with certain parameters?

  • How about using devilspie/gdevilspie to move the window automatically to a different workspace? – pomsky Dec 16 '18 at 14:17
  • 2
    Do you have any other "Workspace" GNOME extensions installed? I use "Auto Move Windows" to start some of my apps on workspaces 2/3/4, and workspace 1 still shows up after logging in. – heynnema Dec 16 '18 at 16:43
1

The solution to this required a bit of trickery:

The GNOME extension Auto Move Windows is able to place a program window on a different workspace if dynamic workspaces are disabled in Tweaks. However, it will also switch to that workspace if no other program is open.

The way to solve this at startup is to use xdotool to synthesize a keyboard shortcut to switch workspaces. E.g.:

  1. Add your startup programs in Tweaks.
  2. Add the same programs to Auto Move Windows and select the appropriate workspace.
  3. Define a keyboard shortcut to switch to an empty workspace, in my case I used Ctrl+Alt+1.
  4. Setup a startup bash script with these two lines:

    sleep 2
    
    xdotool key ctrl+alt+1
    

This way your programs should open on another workspace than the first one and xdotool will switch to an empty workspace at start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.