I have a problem with my new install of xubuntu 18.04.1: Firefox uses about 58% of my 2GB of memory.

On my old install of Xubuntu 16.04 it used about 400 Mb and I don't know where the difference suddenly comes from.

I can find on the web some things about changing preferences but that is not the answer I think. It should work after a clean install.

I only found this but the last entry is about 2 months old


screenshot of system monitor

Hope that somebody can help.


I think it's just a problem that firefox is getting to big, and xubuntu and kubuntu with there choice of firefox as there browser, that they no longer are a low system requirements operating system.
For sure not a 512 Mb.

Firefox has a page about speeding up firefox the address is.


And you can do something about multiple processes that firefox opens and you do that in preferences see picture here set them to 1.

set processes to one

  • Does whatever you've posted as an answer improve things compared to "58% of my 2GB of memory"? – DK Bose Dec 18 '18 at 0:56
  • I did what the support page from mozzila told me, but it didn't work, so it's no the answer. It just made it use less processes like 3, but made it use more memory like 66% and not less. – firewire-p5k Dec 19 '18 at 9:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.