0

I am running Ubuntu MATE 18.04 LTS. A week or two back, the software update tool started coming up with the following message:

Not all updates can be installed. Run a partial upgrade to install as many updates as possible.

This can be caused by: [...]

When I click Continue, it tries to start a distribution upgrade, which I have canceled so far.

I have enabled distribution upgrades only for new LTS versions (which are not due for more than another year), thus I am wondering what kind of distribution upgrade is supposedly going on here. The updater does not mention what the new distribution would be.

What is happening here? And how can I get back to normal system updates without risking to corrupt anything (or upgrade to a distribution I did not want)?

EDIT:

Output from apt update:

Hit:1 http://archive.canonical.com/ubuntu bionic InRelease
Hit:2 http://ubuntu.uni-klu.ac.at/ubuntu bionic InRelease                                                                           
Get:3 http://ubuntu.uni-klu.ac.at/ubuntu bionic-updates InRelease [88.7 kB]                                                         
Hit:4 https://apt.syncthing.net syncthing InRelease                                                           
Get:5 http://ubuntu.uni-klu.ac.at/ubuntu bionic-security InRelease [83.2 kB]                                  
Get:6 http://ubuntu.uni-klu.ac.at/ubuntu bionic-updates/main i386 Packages [404 kB]
Get:7 http://ubuntu.uni-klu.ac.at/ubuntu bionic-updates/main amd64 Packages [460 kB]
Get:8 http://ubuntu.uni-klu.ac.at/ubuntu bionic-updates/universe amd64 Packages [595 kB]
Get:9 http://ubuntu.uni-klu.ac.at/ubuntu bionic-updates/universe i386 Packages [589 kB]                                              
Fetched 2,220 kB in 10s (222 kB/s)                                                                                                   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
396 packages can be upgraded. Run 'apt list --upgradable' to see them.

Output from apt upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  geoip-database-extra gir1.2-gmenu-3.0 libaccounts-glib0 libaccounts-qt5-1 libgnome-menu-3-0 libjs-coffeescript libjs-openlayers
  libsignon-extension1 libsignon-glib1 libsignon-plugins-common1 libsignon-qt5-1 libudev1:i386 libwireshark10 libwiretap7
  libwnck-common libwnck22 libwscodecs1 libwsutil8 python-aptdaemon python-aptdaemon.gtk3widgets python-attr python-automat
  python-click python-colorama python-constantly python-debian python-defer python-dirspec python-hyperlink python-incremental
  python-piston-mini-client python-pyasn1 python-twisted-bin python-xapian python3-blinker python3-jwt python3-oauthlib
  python3-piston-mini-client ruby-afm ruby-ascii85 ruby-blankslate ruby-classifier-reborn ruby-coderay ruby-coffee-script
  ruby-coffee-script-source ruby-colorator ruby-execjs ruby-fast-stemmer ruby-ffi ruby-hashery ruby-jekyll-coffeescript
  ruby-jekyll-feed ruby-jekyll-gist ruby-jekyll-paginate ruby-jekyll-sass-converter ruby-jekyll-watch ruby-json ruby-kramdown
  ruby-launchy-shim ruby-liquid ruby-listen ruby-mercenary ruby-mime-types ruby-mime-types-data ruby-multi-json ruby-oj ruby-parslet
  ruby-pdf-core ruby-pdf-reader ruby-pg ruby-posix-spawn ruby-prawn ruby-prawn-table ruby-pygments.rb ruby-rb-inotify ruby-rc4
  ruby-rdiscount ruby-redcarpet ruby-rouge ruby-safe-yaml ruby-sass ruby-sequel ruby-sequel-pg ruby-stringex ruby-toml ruby-ttfunk
  ruby-yajl signon-plugin-oauth2 signon-ui-service signon-ui-x11 signond software-center-aptdaemon-plugins unity-asset-pool
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  bubblewrap libgles1 libmaxminddb0 libqgsttools-p1 libqt5multimedia5-plugins libqt5multimediawidgets5 libwireshark11 libwiretap8
  libwscodecs2 libwsutil9 linux-headers-4.15.0-42 linux-headers-4.15.0-42-generic linux-image-4.15.0-42-generic
  linux-modules-4.15.0-42-generic linux-modules-extra-4.15.0-42-generic linux-tools-4.15.0-42 linux-tools-4.15.0-42-generic
  python3-netifaces
The following packages have been kept back:
  libssl-dev libssl1.1 nodejs nodejs-dev
The following packages will be upgraded:
  apparmor apport apport-gtk apt apt-transport-https apt-utils apturl apturl-common autopoint bind9-host binutils binutils-common
  binutils-x86-64-linux-gnu bsdutils chromium-codecs-ffmpeg-extra clamav clamav-base clamav-freshclam clamdscan cpp cpp-7 cups
  cups-bsd cups-client cups-common cups-core-drivers cups-daemon cups-ipp-utils cups-ppdc cups-server-common curl desktop-file-utils
  distro-info-data dnsutils dpkg dpkg-dev enigmail fdisk firefox firefox-locale-en flashplugin-installer fonts-liberation
  fonts-liberation2 fonts-noto-color-emoji fonts-opensymbol friendly-recovery fwupd g++ g++-7 gcc gcc-7 gcc-7-base gcc-8-base
  gcc-8-base:i386 gettext gettext-base ghostscript ghostscript-x gir1.2-javascriptcoregtk-4.0 gir1.2-packagekitglib-1.0
  gir1.2-snapd-1 gir1.2-totem-1.0 gir1.2-udisks-2.0 gir1.2-webkit2-4.0 git git-gui git-man git-svn gitk gnome-desktop3-data
  gnome-settings-daemon-schemas grub-common grub-pc grub-pc-bin grub2-common hwdata imagemagick imagemagick-6-common
  imagemagick-6.q16 initramfs-tools initramfs-tools-bin initramfs-tools-core kmod libapparmor-perl libapparmor1 libappstream4
  libapt-inst2.0 libapt-pkg5.0 libasan4 libatomic1 libbind9-160 libbinutils libblkid1 libblkid1:i386 libbrotli1 libcc1-0 libcilkrts5
  libclamav7 libconfuse-common libconfuse2 libcups2 libcups2:i386 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1
  libcurl3-gnutls libcurl4 libdns-export1100 libdns1100 libdpkg-perl libegl1 libfdisk1 libfreerdp-client2-2 libfreerdp2-2 libfwupd2
  libgcc-7-dev libgcc1 libgcc1:i386 libgfortran4 libgl1 libgl1:i386 libgles2 libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin
  libglib2.0-data libglib2.0-dev libglib2.0-dev-bin libglvnd-core-dev libglvnd-dev libglvnd0 libglvnd0:i386 libglx0 libglx0:i386
  libgnome-desktop-3-17 libgomp1 libgs9 libgs9-common libimage-magick-perl libimage-magick-q16-perl libirs160 libisc-export169
  libisc169 libisccc160 libisccfg160 libitm1 libjavascriptcoregtk-4.0-18 libkmod2 libkpathsea6 libldap-2.4-2 libldap-common
  liblouis-data liblouis14 liblsan0 liblwres160 libmad0 libmagick++-6.q16-7 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra
  libmagickwand-6.q16-3 libmetacity1 libmount1 libmount1:i386 libmpx2 libmspack0 libmysqlclient20 libmysqlclient20:i386
  libnautilus-extension1a libnm0 libnss-systemd libobjc4 libopengl0 libpackagekit-glib2-18 libpam-systemd libparted-fs-resize0
  libparted2 libperl5.26 libplymouth4 libpoppler-glib8 libpoppler73 libpq-dev libpq5 libptexenc1 libpython2.7 libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libpython3-dev libpython3-stdlib libpython3.6 libpython3.6-dev libpython3.6-minimal
  libpython3.6-stdlib libquadmath0 libraw16 libreoffice-avmedia-backend-gstreamer libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-help-en-us libreoffice-impress
  libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-style-galaxy libreoffice-style-human
  libreoffice-style-tango libreoffice-writer libruby2.5 libsmartcols1 libsmbclient libsnapd-glib1 libsnmp-base libsnmp30 libssh-4
  libssh-gcrypt-4 libssl-doc libssl1.0.0 libssl1.0.0:i386 libstdc++-7-dev libstdc++6 libstdc++6:i386 libsynctex1 libsystemd0
  libsystemd0:i386 libtexlua52 libtexluajit2 libtotem0 libtsan0 libubsan0 libudev-dev libudev1 libudev1:i386 libudisks2-0 libuuid1
  libuuid1:i386 libvlc-bin libvlc5 libvlccore9 libwavpack1 libwbclient0 libwebkit2gtk-4.0-37 libwinpr2-2 libwireshark-data libwoff1
  libxkbcommon-dev libxkbcommon-x11-0 libxkbcommon0 linux-firmware linux-generic linux-headers-generic linux-image-generic
  linux-libc-dev linux-tools-common linux-tools-virtual man-db metacity-common module-init-tools mount netplan.io network-manager
  networkd-dispatcher nodejs-doc nplan nvidia-prime openjdk-11-jdk openjdk-11-jdk-headless openjdk-11-jre openjdk-11-jre-headless
  openjdk-8-jdk openjdk-8-jdk-headless openjdk-8-jre openjdk-8-jre-headless openssh-client openssh-server openssh-sftp-server
  openssl packagekit packagekit-tools parted perl perl-base perl-modules-5.26 plymouth plymouth-label plymouth-theme-ubuntu-text
  poppler-utils ppp python-apport python-apt python-apt-common python-lxml python-problem-report python-requests python-samba
  python2.7 python2.7-dev python2.7-minimal python3 python3-apport python3-apt python3-dev python3-distupgrade python3-distutils
  python3-gdbm python3-lib2to3 python3-louis python3-minimal python3-problem-report python3-requests python3-software-properties
  python3-tk python3-update-manager python3.6 python3.6-dev python3.6-minimal rfkill ruby2.5 ruby2.5-dev ruby2.5-doc samba-common
  samba-common-bin samba-libs secureboot-db shotwell shotwell-common smbclient software-properties-common software-properties-gtk
  ssh syncthing systemd systemd-sysv texlive-binaries thunderbird thunderbird-locale-en thunderbird-locale-en-us totem totem-common
  totem-plugins tzdata ubuntu-drivers-common ubuntu-keyring ubuntu-mono ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk
  udev udisks2 ufraw-batch unattended-upgrades uno-libs3 update-manager update-manager-core update-notifier update-notifier-common
  ure usbmuxd util-linux uuid-dev uuid-runtime valgrind virtualbox virtualbox-dkms virtualbox-qt vlc vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization wavpack wireshark wireshark-common wireshark-qt xdg-utils xserver-common
  xserver-xorg-core xserver-xorg-legacy xul-ext-calendar-timezones xul-ext-gdata-provider xul-ext-lightning
392 upgraded, 18 newly installed, 0 to remove and 4 not upgraded.
Need to get 789 MB of archives.
After this operation, 539 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
  • Please show us the complete output of apt update and apt-upgrade (NOT dist-upgrade). – user535733 Dec 15 '18 at 17:39
  • The links of repositories looks very much different from traditional links of repositories. Which server are you using? – Kulfy Dec 15 '18 at 18:15
  • For Ubuntu I use the mirror at ubuntu.uni-klu.ac.at/ubuntu – user149408 Dec 15 '18 at 18:29
  • Just switched to the main repository, still the same behavior. Same after disabling the syncthing repo and sisabling distribution upgrades altogether. – user149408 Dec 17 '18 at 21:34
  • Tried sudo apt-get update annd sudo apt-get upgrade, installing all package updates. Still the same when I run Software Updatrer after that. – user149408 Dec 17 '18 at 22:49
1

Thanks to this and this answer, I have been able to resolve the issue.

Apparently “distribution upgrade”, as shown in the window title, is a misnomer. There is no distribution upgrade happening here, just an upgrade with some particularly complex package dependencies.

Just going through with the partial upgrade, as the first answer suggests, would probably have been fine and still left me at my current distro, with the necessary updates installed.

I went for the second approach, running sudo apt-get update && sudo apt-get upgrade once to install all upgrades, and taking note of all packages marked as being held back. For these, I went into Synaptic and seleted each for upgrade, confirming dependencies as I did. After applying changes and waiting for the installation to complete, I am no longer being prompted for a partial upgrade.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.