1

I have problem with scanning on LJ M1132 MFP printer/scaner. My search on many various forums did not get anywhere so I try to ask directly if someone can help me.

I recently reinstall system from Mate 16.04. to Ubuntu 18.04. In 16.04. the scanner had no problems. After installation of new system I had problems even with the printing. I installed newest hplip. Printing works for some time but scanning was not possible. All the time it show i/o problems.

For example "simple scan" shows warning "Unable to connect to scanner".

If I run

hp-scan

it comes with "error: SANE: Error during device I/O (code 9)"

I try several tips, like reinstalling hplip, so now I have instaled 3.18.6 version, but no change in scanning.

If I run

hp-check -t

from my point important part of output is

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.18.6
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro  18.04 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.18.6

----------------------
    | Scan Configuration |
    ----------------------

     scanext              Scan-SANE-Extension                                          REQUIRED        -               3.18.6          OK         -
     hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.18.6          OK         'hpaio found in /etc/sane.d/dll.conf'


    ------------------------------
    | DISCOVERED SCANNER DEVICES |
    ------------------------------

    device `hpaio:/usb/HP_LaserJet_Professional_M1132_MFP?serial=000000000QH6ADT0PR1a' is a Hewlett-Packard HP_LaserJet_Professional_M1132_MFP all-in-one

    --------------------------
    | DISCOVERED USB DEVICES |
    --------------------------

      Device URI                        Model                           
      --------------------------------  --------------------------------
      hp:/usb/HP_LaserJet_Professional  HP LaserJet Professional M1132  
      _M1132_MFP?serial=000000000QH6AD  MFP                             
      T0PR1a                                                            
    --------------
    | PERMISSION |
    --------------

    USB             HP_LaserJet_Professional_M1132_MFP Required        -        -        OK       Node:'/dev/bus/usb/005/005' Perm:'  root  lp rw- rw- rw- rw- r--'
    No errors or warnings.

As was suggested to install Plug-in, it is already installed together with the hplip. Even for printing my printer needs Plug-in. For versions of hplip 13.16.9 and 13.18.6 which were installed on my computer (together with similar version of plug-in) printing was working but scaner no. And my printer is not the latest model, according to the https://developers.hp.com my printer should be supported with hplip from version 3.10.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.