Okay, so I had a dual boot of Tango Studio (based on Ubuntu 10.04) and Windows XP.

Yesterday I downloaded the .iso for Ubuntu 11.10 and attempted to install from a USB (my BIOS won't normally boot from USB but I had PLOP boot manager on a CD). I booted up Ubuntu from the USB and then from there formatted the partition with Tango on and installed Ubuntu 11.10. On booting up I came into Grub rescue mode. So I booted up from the USB again and used boot-repair to reinstall Grub.

After this I would see the normal Grub menu, but on choosing Ubuntu I would come to a black screen. On choosing recovery mode it would begin starting normally with no obvious errors but instead of coming to a cli I would just get a blank screen with a flashing cursor on the top left, not accepting any input.

I have since reformatted and reinstalled from a CD rather than USB and had the exact same problem. I used boot-repair again and the result is the same. Output of the most recent boot-repair is at http://paste.ubuntu.com/869805/

I have also tried editing the ubuntu grub entry and replacing quiet with text nomodeset as I saw in an answer to another question. This got me a bit further - I saw the purple ubuntu loading screen but still came to a blank screen after that. Anyway, in most of the other questions in which that is brought up the user is still able to boot into recovery, while I am not.

Can anyone help? Thanks in advance, let me know if there's any more info I need to provide!


I read something saying it's quiet splash that should be replaced with nomodeset. Earlier I had left splash in the line. So i tried it this way and it froze after displaying the following text:

fsck from util-linux 2.19.1
mountall: Plymouth command failed
mountall: Disconnected from Plymouth
/dev/sda5:clean, 139359/1741488 files, 745830/6961125 blocks

From a bit of googling it doesn't look like plymouth is essential, but I've checked and I do have the most current versions of mountall and plymouth installed so I don't know why there's a problem


I used dkpg --reconfigure plymouth cause I saw it mentioned in another forum and it still says plymouth command failed on boot


Unfortunately I was not able to get this working. I needed it working and switched distribution before anyone commented or answered this question, so am unable to try out any suggestions posted here

I'm thinking of giving this another go sometime soon, if I do then I'll report back.

  • how old is this PC? Sometimes old and buggy video cards behave this way.. – deckoff Apr 25 '12 at 10:34
  • maybe this will help: askubuntu.com/questions/136094/ubuntu-boots-but-gives-no-screen – Dr_Bunsen May 13 '12 at 9:54
  • @deckoff I think it's six years old, though I'm not sure as I'm not the original owner. It has an nVidia GeForce Go 7400, which I think is an okay card though yeah it's getting a bit dated. The card is currently running Gnome 3 on a different dist – user1092284 Jul 5 '12 at 18:55

I had same problem with my Acer-Aspire.

What I did, If you have already installed the Ubuntu and you can see the link in grub, you do one thing. This is not the absolute answer but at least you can see your screen.

Choose your Ubuntu option and click:


to edit grub. Now go to one line before the end where you can see the words quiet splash; after you put one space and type this:


and then




to save this grub temporary for this time. Now it will boot and after a while when you saw the black screen, you hold

Fn+Left/Right Arrow

Left/Right arrows means that [Left or Right]. One of them, I prefer Left.

Your screen should be back. OK, you login through your username.

And now, if you would like to make it permanently workable but with one more step (Fn+Left/Right Arrows) you have to edit the grub and update it.

OK, If you like lets do that. Open terminal or hold on (Ctrl+Alt+T) and write this code:

sudo gedit /etc/default/grub

put your root password.

One page will be opened. You go to line 11 [this no is with counting one empty line], where you can see this command:


Exactly after the word splash, you add same thing which you add in the grub at past. Add one space and this command:


and save it. Now your line must be like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

OK, go back to terminal and see the file is closed.

Now one thing is remain; you run this code in terminal to update the grub:

sudo update-grub

put your root password and you are done. Just every time that you want to come you have to Hold [Fn+Left/Right] to see your screen.

I hope this is helpful for you.

  • Not in a position to give this a try anymore, but thanks for posting. Good, thorough instructions, so hopefully they'll help someone. – user1092284 Jul 5 '12 at 19:04

When the error appears and ask you to choose between recovery mode or others, pick others and press E. Then F10 and press any key, then press F10 again till it works.

  • 1
    I've updated the question to show that I'm unfortunately not in a position to give this a go anymore. As far as I remember though, 'Others' wasn't an option I was ever given – user1092284 Jul 5 '12 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.