1

I am currently having a "small" problem getting my Nvidia drivers to work. It is identical to this post: NVidia X Server Settings GUI doesn't start on ubuntu 18.04

I however have not installed CuDNN and TensorFlow-GPU.

$ uname -a
Linux OVG-HP 4.19.9-041909-generic #201812130432 SMP Thu Dec 13 
09:34:53 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

The error/bug:

$ nvidia-settings

ERROR: Unable to load info from any available system


(nvidia-settings:9737): GLib-GObject-CRITICAL **: 21:50:05.392: 
g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:9737): WARNING **: 21:50:05.394: PRIME: Failed to 
execute child process “/usr/bin/prime-supported” (No such file or 
directory)
** Message: 21:50:05.394: PRIME: is it supported? no

I also tried to do nvidia-xconfig:

$ nvidia-xconfig

WARNING: Unable to locate/open X configuration file.


WARNING: Unable to parse X.Org version string.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found

ERROR: Unable to write to directory '/etc/X11'.

Seems to me that I am missing "bunch" of files to run Nvidia driver, even if this is a fresh install of it (was just reinstalling). I have tried searching around for this behaviour but haven't really found much that helps.

Could this be caused of nomodeset in my grub? I noticed that I am also missing some folders from Intel, basically to control the screen brightness. I saw that happen from when I restarted after adding nomodeset to grub. The computer however won't run unless it has nomodeset.

If this is a bug, I will do my best to report it to developers. If not, all help is welcome. :)

migrated from meta.askubuntu.com Dec 14 '18 at 22:54

This question came from our discussion, support, and feature requests site for Ubuntu users and developers.

  • Where did you install that Kernel from? What version of Ubuntu are you running? Was there a problem with the kernel that comes with the version of Ubuntu you are running? There is a chance that the driver or nvidia-settings may not work with an unsupported kernel version. – Terrance Dec 15 '18 at 4:24
  • I installed it with ukuu. There was nothing "wrong" with the 4.15 kernel, but the difference is that the computer runs colder now (much less ramping up fans). I had the this problem on Ubuntu 18.04 and after my newest reinstall I use Linux Mint 19 (which is a derivative of Ubuntu 18.04). I had EXACT same problem in Ubuntu 18.04. – Ólafur Víðir Guðbjargarson Dec 15 '18 at 7:43
  • Since the Kernel is not a version that is currently supported in the stable releases I would recommend that you file a bug against the driver or the nvidia-settings app for that specific kernel. – Terrance Dec 16 '18 at 5:45
  • Well, I do get exact same results on kernel 4.15 (might have put that better in my question) as on kernel 4.19.9. I have the drivers installed but there seem like there are "bunch" of files missing. – Ólafur Víðir Guðbjargarson Dec 16 '18 at 8:50
  • I found the same problem over here askubuntu.com/questions/1087714/… I had to dig pretty much to find it. – Ólafur Víðir Guðbjargarson Dec 16 '18 at 9:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.