0

I did an ubuntu upgrade this morning and when I reboot the machine, chromium-browser will not run. I purged it with sudo apt-get purge chromium-browser and reinstalled it with sudo apt-get install chromium-browser.

When I try to run it from a terminal I get a message like: ATTENTION: default value of option force_s3tc_enable overridden by environment. [22032:22032:1214/132224.411454:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.

The command hangs and I have to ctrl-c to get the shell back. No chromium processes are running when it is done.

If while the command is hung I get and I check for processes I see 5

1) --enable-pinc
2) --type=zygote
1) --type=gpu-process -- field-trial-handle=somelongnumber --gpu-preference=KAA...
1) --type=-broker

Does anyone have any suggestions?

Edit: I decided on a whim to run sudo chromium-browser, got an error message about not using the option --no-sandbox. I ran with sudo chromium-browser --no-sandbox and it seemed to work, I got a dialog that said "Profile error occured" Your preferences could not be read?

I then pinned the browser to the Launcher and it runs without sudo but I always get the "Profile error occured " dialog. It won't save preferences, and some features are unavailable.

  • One recent answer quoted workaround for Ubuntu 14.04 and Chromium 53, but the question does not have such information. Consider to edit your question and include: 1. Which release of Ubuntu? 2. Which version of Chromium browser? – clearkimura Dec 26 '18 at 16:10
0

From this bug report on Launchpad, there is one suggestion found in the comments.

Henry Wertz (hwertz10) wrote on 2016-11-04:

[...] I have an Acer Chromebook 13 (Tegra K1) which had 14.04 on it; Chromium 52 or 53 worked fine. Went to 16.04 (managing to hold back X so I could keep the nvidia driver...) and chromium blew up as others have reported.

I also found the 14.04 build of (at this point, chromium 53) worked fine after I set "--disable-namespace-sandbox"... I had the "Aw, snap!" but found (per google) that "--disable-namespace-sandbox" fixed it without the ill effects of "--no-sandbox".

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.