3

I created a brand new Ubuntu vm with beaver GUI but can't install wireshark on it.

I used the steps provided on this answer to get wireshark from ppa, but I get errors of dependencies or something...

STEPS:

$ sudo add-apt-repository ppa:wireshark-dev/stable
$ sudo apt-get update
$ sudo apt-get install wireshark

ERRORS: enter image description here

EDIT 1: I tried to install wireshark-qt but I get the same type of error... enter image description here

EDIT 2: I tried solutions from this post, but none seem to help my case.

$ sudo apt-get autoremove
$ sudo apt-get update
  • 2
    Possible duplicate of Unable to correct problems, you have held broken packages – karel Dec 14 '18 at 13:39
  • I tried the many solutions provided by your link, but without success... $ sudo apt-get autoremove and $ sudo apt-get update didn't change a thing.. ): Thanks for your help! I'll keep looking for a solution. – LoukMo Dec 14 '18 at 13:45
7

You're trying to install from the Wireshark development PPA. It probably needs resources that are not available on 18.04.1.


Update #1:

There could also be a problem with "Beaver GUI"... I'm not familiar with it. Sounds like GNOME desktop.

This originally started as a server install, and other resources may be missing that are required for Wireshark.


Remove or disable the PPA.

Then checkmark the following Ubuntu repositories... and reload the databases on quit...

enter image description here

Then install Wireshark from Synaptic, the Software Center, or...

In terminal...

sudo apt-get update # update the software databases

sudo apt-get install wireshark # install wireshark

  • So the problem is coming from the PPA repo. Thanks for the quick help! (: – LoukMo Dec 14 '18 at 14:28
  • @LoukMo also check your "Beaver GUI". – heynnema Dec 14 '18 at 14:34
  • The "Beaver GUI" I'm referencing to is (I think) the basic one you get from doing this post's commands... sudo apt-get install ubuntu-desktop I thought it was called beaver because there's a beaver as default wallpaper... hahah – LoukMo Dec 14 '18 at 14:44
  • 1
    @LoukMo That's probably GNOME desktop. Was/is your installation originally a server install? – heynnema Dec 14 '18 at 14:47
  • 1
    @LoukMo ah... that's why you needed to install ubuntu-desktop. There may be other resources missing in server that are required for Wireshark. Is Wireshark working for you now? – heynnema Dec 14 '18 at 14:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.