0

screen photo

Anyone can help me? I am using Samsung SSD external disk installed Ubuntu 18.04. It appears this kind of problem when I keep it aside for a while.

  • Do you dual-boot with Windows? Do you know how to fsck the drive? Have you checked for Samsung firmware updates? – heynnema Dec 14 '18 at 14:44
  • @heynnema Not really dual-boot with Windows, the external SSD has partitioned a EFI space. I tried fsck, but nothing changed. Feel so confused. – James Yuan Dec 21 '18 at 9:21
  • Did you check for Samsung firmware updates yet? What fsck command did you use? You probably need to backup your files, wipe the drive with a new MBR/GPT partition table, and reinstall Ubuntu. Keep in mind that your SSD may be bad... you can use the Disks app to check the SMART Data & Tests. – heynnema Dec 21 '18 at 14:01
  • Hi Heynnema, This is a brand new SSD, also I tried on 3 SSD(external and internal). I used fsck /dev/sd2 command. – James Yuan Dec 22 '18 at 23:23
  • I checked SMART by CrytalDiskInfo, the disk is showed with good health. – James Yuan Dec 22 '18 at 23:47
0

Basically, the power saving features of your drive are triggering a bug that leads to the failures you're seeing - disk io errors.

Typical symptoms are the logs you show above, fonts not rendering, and your desktop environment crashing. While the issue has been identified for some SSDs, it is still a problem for some of us. I am also experiencing this issue.

Workaround

As a workaround, You can prevent this by adding this to your start script in grub:

nvme_core.default_ps_max_latency_us=6000

Although, others report that only by setting the value to 0 will you stop running into the error. Of course, then your SSD's power performance suffers.

The real bug

This is a bug that is partially reported here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1805816

If you want to help fix the real problem, add more details about your problem in your initial question here in SO and in the bug tracker I link to above. For example, Look at the person who opened the ticket to see what relevant info he included. I'm just starting to tackle this myself by adding my details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.