1

I have installed hplip and hplip-gui but when I am running hp-toolbox from terminal it says:

Command 'hp-toolbox' not found, but can be installed with:

sudo apt install hplip-gui

Before this, I was trying to print a pdf file using hp laser-jet 1018, but hp-toolbox had an error about pyqt5widget saying:

The .so file cannot import: "failed to map segment from shared object"

After that, I tried to install hplip from .run file provided in hp's site but it also has failed. Now how can I install hplip correctly?!

In this post it is explained how to install the hplip but my problem is not that! At the moment when I am trying to install hplip and hplip-gui using apt-get I get the message:

hplip is already the newest version (3.17.10+repack0-5).

hplip-gui is already the newest version (3.17.10+repack0-5).

but when running hp-toolbox, it says it is not installed.

And when I try to install hplip using the .run file from official link, I get error in make step (error code 2).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.